Streaming live at 10am (PST)

Problem with footer when exporting code


#1

Hey,

I've just finished my site design in Webflow and am ready to export. However I've noticed one issue that only happens when the code is exported, which I can't seem to fix.

Here's the site: https://preview.webflow.com/preview/we-rate-the-best?preview=f809b65720154b90bf0c16f75120a2dd

If you notice the footer in the editor when you preview the site, it's normal. Even when I publish the site on the temp .io domain, the footer looks fine.

But, when I export the site, then open it up locally in Chrome. This happens:

It happens on all screen sizes too.

I've played around with the positioning, but I just can't seem to make it work when the code is exported. Everything else seems fine, it's just the footer.

Thanks!
Andrew


Here is my public share link: LINK
(how to access public share link)


#2

As far as I can see in the editor and preview, it all seems to work OK.

Sometimes things just don´t work "local". I´ve had numerous times that strange things happen when viewing the site local. Once uploaded, all was fine.

Perhaps you can use the inspector in google chrome to see what might be going wrong?

I see the logo´s are text and not images. Bear in mind that the rendering of fonts might be different in certain browsers and might cause these strange things.

If all else fails, can you try the following flexbox-settings for the "Footer Social Icons" DIV;

Bear in mind you will have to remove the 2px top margin of the Google+ Logo.


#3

The flex settings worked! You genius :grinning:

Thanks for the help, it was driving me mad. Never used the flex settings before.


#4

Ah, I spoke to soon.

It worked locally, but I uploaded the new files to my host and it's still the same:

http://weratethebest.com/webflow/

Damn.


#5

Yeah, very strange.

So it works locally, on the .io domain but not on my host as a static site.


#6

Then, while leaving flexbox in place, just set your width of the DIV containing the logo´s to 90px.

The DIV is to narrow for the text to render good. Will sort it once and for all :wink:


#7

It worked! Yay.

Thank you Tom, much appreciated! :grin:


#8

You´re welcome! Glad to be of service :slight_smile:


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.