Streaming live at 10am (PST)

Problem with mobileversion of my site


#1

Hi guys

I am still new to the Webflow-designer and I am having a trouble making my site mobile-friendly. After setting up the mobile-part I am experiencing that the whole page can be moved to the right (if you drag). Like there is something floating outside the editor. It is kindda hard for me to explain but I have attached to screenshots to show you what I mean. It only happens when I “toggle preview”.
Do you know how to fix it?

Best,
Rasmus
https://preview.webflow.com/preview/duehammershoy?preview=c8e6158bf52fd3e99cf69e678cc5ca3d


#2


#3

Totally something floating around (most probably). Things to do:

  1. locate the section containing the faulty element. If you can’t decide which one it is, delete them one by one and check for the problem after each delete. When you know which section it is, CMD-Z your way to the original state.
  2. fix the problem, 2 ways
    2.1 fix the faulty element inside of the section you identified. Most likely and element with a width set in px that you need to change to 100%, or an element that is moved out of the page with an interaction set on it to make it slide in, or a 100% element inside of an element with padding…
    2.2 give the whole section the overflow:hidden property so everything bleeding outside isn’t taken into account for the viewport size. (this is the solution for elements moved with interactions)

I can’t reproduce the issue on your site though… it’s fine to me.


#4

Great, thank you so much :slight_smile: