Streaming live at 10am (PST)

Problem with og Meta Tags for Facebook post link image preview picture

I’m trying to provide a link in a Facebook post and use the og mega tags so that FB creates an image preview for the image I choose. However, it’s not picking it up and when I run Facebook debugger, I get one of two error messages.

My meta tags:

Error Messages:

Error while downloading http://www.dilloncarlyon.com/wp-content/uploads/tychewall w gray border.jpg with HTTP response code: 400

Provided og:image, [http://www.dilloncarlyon.com/wp-content/uploads/tychewall w gray border.jpg] could not be downloaded. This can happen due to several different reasons such as your server using unsupported content-encoding.

I’ve checked several times and the links in the meta tags are correct, and the image does exist in the specified location on my website.

Can someone help me with this?

Sorry, left out the meta tags. Here they are. They are in the correct section (head).

meta charset="<?php bloginfo( 'charset' ); ?>>
meta name=“viewport” content=“width=device-width”>
meta name=“description” content=“Dillon Carlyon”>
meta name=“keywords” content="astrology,astrological ">
meta property=“og:title” content=“Dillon Carlyon Astrology”>
meta property=“og:url” content=“http://www.dilloncarlyon.com/weeklyaspects.html”>
meta property=“og:image” content=“http://www.dilloncarlyon.com/wp-content/uploads/tychewall w gray border.jpg”>
meta property=“og:description” content=“Weekly Planetary Aspects”>

Hi,
I’m seeing the same issue - same two error messages.
Did you get anywhere with this?