Streaming live at 10am (PST)

Problem with ssl enabling


#1

Hi.
In order to add my website security, i've successfully followed these steps:

So currently these are my DNS records:

When I went back to Webflow and enabled SSL, I received these messages:

Following option 2, i've changed the CNAME record, but the domain keeps being unlinked.

Can anyone tell me what am I doing wrong?

Thank you,
Naama.


#2

You have the incorrect A Records in there, currently they are the non-SSL Webflow A Records.

Update them to be:
34.193.204.92
34.193.69.252

Then you'll be good to go!


#3

Thank you @LJB for your response, but what's written in the instructions, is that I should change the A records as you wrote only if I want www.nbl-design.com to be the default domain and that is not the case. I want nbl-design.com to be the default domain.


#4

the A Records I wrote are the SSL A Records. Once you correct the A Records to this, you can still choose either the www. or non-www. domain to be the default. If you don't want SSL, and really want to keep those A Records you can simply change the CNAME to proxy.webflow.com; either way it will have no effect on the default domain.


#5

Thanks @LJB
I had to disable and enable the http proxy on cloudflare (clicked on the orange cloud and then click again on the gray cloud) for the CNAME record pointing from www to proxy.ssl-webflow.com and also changed this pointing to proxy.webflow.com
Does this make sense?

On Webflow still the domain is unlinked and when you try addressing the non-www domain you always get the www domain.


#6

Hi @Naama, sorry to hear about the trouble with the custom domain.

First, you were correct to disable the proxy on Cloudflare side, that will cause the unlinking. The orange cloud should be clicked and disabled in the Grey state using the DNS only option.

Next, there are two ways to setup SSL for a domain.

Using WWW as the Default Domain

  1. Point the A Records at the IP addresses found on the SSL instruction page
  2. Point the www domain via CNAME record to proxy-ssl.webfow.com
  3. Set the www domain as the default domain
  4. Republish

Using the Root Domain as the Default Domain, and with SSL Enabled

  1. Point the Root domain via CNAME record to proxy-ssl.webfow.com
  2. Point the www domain via CNAME record to proxy-ssl.webfow.com
  3. Set the root domain as the default domain
  4. Republish

I hope this helps, if not, send an email to support@webflow.com and I will be happy to take a look further.


#7

Thank you very much @cyberdave, I've used your the second option and it worked like a charm!


#8

This topic was automatically closed after 60 days. New replies are no longer allowed.