Streaming live at 10am (PST)

Problem with "Trigger-Load" - Animations from the page are starting before Pageloader is ending!


#1

Hey guys,

I don’t know why but the page loader isn’t working as expected. The problem is that I sometimes don’t see the transitions (animations) from the main page when I'm loading the site. When I reload a page again, I see the transitions (animations) - but in 90% of the cases when I open the page for the first time - the transitions (animations) are not visible.

I don't know why but the transitions (animations) from the main page are starting in the background while the pageloader is active - and not after the loop as expected. What I want is that the transitions (animations) should start after the loop transitions (animations) is ended.

I saved the "TriggerLoader" with the setting „Wait to assets to load“. But the animations from the main page are starting before the TriggerLoader (Loop) is ending.

Any ideas?

Check my read-only link:
https://preview.webflow.com/preview/made444?preview=61332c11d73df14fa1cea76b8fa25356

Cheers
Farid


#2

I would recommend using pace.js instead for your pageloader:
http://github.hubspot.com/pace/


#3

The loader seems fine.

You might want to set your intro animation to a load trigger as well. Set them to wait for the assets to load and give them a wait time slightly longer then the total length of the pre-loader animation.

Right now because you have set the intro animation to scroll you have to guess how long it will take for the page assets to load. Which will be different for different people.

Does that make sense?


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.