Streaming live at 10am (PST)

Property values automatically change randomly


#1

I still cannot reproduce this bug. But it's there...

With a fixed nav... sometimes the bottom margin changes from 0 ZERO to some other value...

such as the one in this image below.

I did not change this value. It was set 0... and if you cannot - the icon to the left is NOT BLUE...
which indicated - I did not change the value.


#2

I have this situation to ... it may just be involved with size of the browser height and how much it must go up to stay at that location. (It changes when you change the browser size.) I really wouldn't worry about it since it has no negative aspect on the website.


#3

Avoid styling the nav as Webflow does it own calculations. If you need advanced positioning and size, create your own custom nav.


#4

@samliew there are only 2 things I am doing with the nav

1 - fixed top
2 - custom branding... and I removed the custom branding to test the issue and the issue was still there.

Strange enough - exiting and re-entering the designer sometimes fixes the issue.


#5

Hi @Revolution, this is certainly weird. Kindly post your public share link so I can take a look.


#6

This is really strange issue.

I did found a work-around / fix for this issue.

In this case... I may be mis-understanding how css or Webflow works...

I created a body class... (for the body of the page.)

The only thing I changed in the class was
- font-class (Raleway 400 Normal)
- background-color (rbga(192,192,192,0.1))
- and child-perspective (1700)

The nav element is FIXED TOP

Webflow would create a555px PADDING-TOPORMARGIN-TOPon thenav element in design, published or exported view.

In testing... this is what I found:

Changing the body child-perspective to any value 1... or 100,000... creates the above 555px nav element issue.

Using any value in body child-perspective
- also auto-changes the nav element position:bottomtosome random px

Notice below the value is 1846. I've seen 1649, 1572, 1920 and several others.

And you notice - the icon is not blue - which means I didn't change the value.
- Webflow did.

The only way to fix this... is to change body Overflow:Hidden on thebody class


- but then of-course... this makes my form non-scrollable.

If I remove the body child-perspective from the body class....

  • and reset the body over:hidden value

  • the 555px issue is fixed

  • but the nav element still maintains a value in position:bottom of 695px.

  • But by the time I captured the screen shot.. the value had changed to 875px.

And neither value... 695 or 875 appears anywhere where in the CSS file.

I'm not sure what this 695 / 875 value is for...

If the value is not used... why is it in the designer. And what is it for ?

Another thing I noticed in the code...
Body min-height is not set...


but in the source code... themin-height is always set to 100%.

I'm not sure if the 695 / 875 issue from above - or this 100% min-height thing it makes any difference.

I'm just pointing that
- there are things happening in the designer
that are
- different than what the source code tells you.


#7

Thanks for your detailed report @Revolution. If you could, please share the public link to your project as well.

@cyberdave: could you please take a look at the above bug report? Thanks!


#8

Hi @samliew and @revolution, thanks for the info. I will start checking, thank you.


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.