Streaming live at 10am (PST)

Proximity of Nav Menu from Hamburger Nav Icon


#1

When I click the hamburger icon to display the nav menu on my mobile phone, the nav menu appears way down the page. In addition, when I click on the menu options, I'm not taken to the corresponding pages.

Here's a read-only link

Please advise. Thanks!


#2

Hi @billf, quick question, are you wanting the mobile nav dropdown to work on tablet and mobile landscape also, or just mobile portrait mode? If you can confirm this, I can check why the mobile menu not showing.

Mobile dropdown links that are part of symbols, do not currently work in preview mode. They will work in the published mode however.

Cheers,
Dave


#3

Hi @cyberdave, I'd like the mobile nav dropdown to work on table and mobile landscape, too. Thanks.


#4

Hi @billf smile

Try moving the slider to the tablet icon. See below:

​Try these steps and let me know if you're successful.


#5

Sorry, not following. Can you please be more specific?


#6

Hi @billf

If you click on the screenshot above, you'll see that I clicked on your nav item, then clicked on settings panel, then slide the menu icon setting.

try that and let me know what happens. smile


#7

Thanks for clarifying. Tried it and it didn't make a difference (at least in preview mode; assuming I don't need to publish to check it). Any other ideas?


#8

it looks like it worked for you. Are you seeing something different than me?


#9

Unfortunately, I'm still seeing the issue. As shown in the attached pic, when you click the hamburger menu, the drop-down is displayed way down the page (and it's not on covering other images).Please advise. Thanks.


#10

Hi @billf ,

Can you try to remove the overflow hidden and position override from your navbar in Desktop view, and then try it again ? It looks like the overrides you have on the navbar may be causing the issue.

Try that and see how it looks. Cheers,
Dave


#11

Hi @cyberdave,

Just saw this and tried it. Didn't seem to make a difference. Would really like to get this fixed soon. Any other ideas?

Thanks,
Bill


#12

Hi Bill, In Tablet Portrait mode, with the navbar in the open state, try giving the navbar position relative:

Cheers,
Dave


#13

That worked! Thanks again Dave.


#14

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.