Streaming live at 10am (PST)

Purchase button doesnt do anything

Hey everyone! So I am currently working on an ecommerce site, selling products that doesnt require shipping and its ready to launch however the client has setup all the payment details and tried to make a test purchase. On the checkout page after clicking the purchase button…nothing happens. Could anyone please help me figure out where I am going wrong? Heres the link-
https://preview.webflow.com/preview/discover-courses?utm_medium=preview_link&utm_source=dashboard&utm_content=discover-courses&preview=2181fa1fb11bd64ddd90c1fd01987898&mode=preview

Paypal or stripe?
Paid plan?
Payment activated?
No demo account/setup in Stripe?

Stripe payment.
Yes it is a paid plan.
Yes payment is enabled.
Not sure but need to check.

Its not possible to se the settings in the preview
Any message from WF?

None :frowning: not sure what to do

What happens when pressing pay?
Be sure that stripe is not in test mode

nothing happens when you click on ‘place order’

let me check with the stripe real quick.

Ok, check with your client about test mode.
I’m on my iPad now so it’s hard to help you now. I can take a look later if you haven’t find the problem
Can you provide a live link

Ofcourse! https://discover-courses.webflow.io/

Thank you soo much!

Have you tested to setup a shipping fee (can be 0). Try that

totally turned the shipping off but yea let me give that a go

Name it free shipping’s

One other thing on top of my head. I’m not sure Stripe setup requires that. But check if Stripe need a web address in the configuration of valid sites. I’m not sure you need to do that. Can’t check my sites right now

Do I turn on shipping here?

Yes, I have products without shipping but it turned on on my sites.
I use weight to set the price to 0. 1 gram per product and then I have a rule saying free shipping for att products under 1000 grams