Streaming live at 10am (PST)

Question about vimeo videos embedded via CMS


#1

For a documentary filmmaker's portfolio site, I've got a dozen or so Vimeo videos / players loaded via dynamic list on the 'work' page. The video plays in a modal popup and there's a little 'close' button that dismisses the modal; I also want it to pause the video (otherwise the audio keeps playing; it's a little surreal).

Problem I'm having is initializing the iframe. When the 'close' button is clicked, I jump up the DOM to the parent and 'find' the iframe with class 'embedly embed'. But when I call the constructor using that iframe, like this:

player = new Vimeo.Player(iframe);

I get the message that I haven't grabbed a Vimeo player. Inspecting the DOM reveals that that iframe has a body with another iframe, which itself has yet another body with a 3rd iframe. It's like Vimeo-ception, all the way down to limbo! Any clues for which element I need to grab to initialize the player object?

Thanks!


#2

do you have a share link. Also seems like an odd question maybe, but why not use built in video embed in webflow?


#3

Site is here: http://all-rise-films.webflow.io/work

I am using a video embed in Webflow, that's part of the problem. The code that Webflow generates for the embed is wonky. It's just a "video" field in the CMS that's expecting a Youtube or Vimeo URL. See here:

The code it generates looks like this:

As you can see, Webflow generates a first iframe, a second iframe, and then a video tag. It's a hot mess of nested embeds, but I guess that's how they set up the "video" field in the CMS to render. My best guess at the moment is the actual player is loaded here:

<video preload src="blob:https://player.vimeo.com...">

I'll try referring to that when initializing and see if I get anywhere. Meantime, if anybody has any insight...


#4

what's your share link?


#5

Posted above, see here:


#6

That is not the share link. That is the webflow published link. Share link let's us see project in designer. If you go into project settings. The top menu
click share will give you an url you can paste in here.

then we can open the site in webflow and see what's working or not working under the hood