Streaming live at 10am (PST)

Quick effect initial state is not affected by interaction viewport triggers


#1

Tell us how to turn off effects so that they do not work in the mobile version.
https://preview.webflow.com/preview/web-64f692?preview=c43b12e05591818ba6882bfa1000504b


#2

Hi there,

From a quick look, there’s a “Trigger on all devices” setting right down the bottom of the Interactions tab, after clicking on the ‘page load’ animation.

Need to be mindful though that this means that the interactions won’t trigger, so, the information you have fading in won’t occur.


#3

this is not the answer I ask!
I’m interested in how to turn off effects in mobile versions?


#4

Do that in the interactions panel of the “animation” at the very bottom.


#5

Show please a screenshot


#6

%40bonidom


#7

this function disables the entire object, and I need to disable the effects in the mobile version



#8

https://preview.webflow.com/preview/web-64f692?preview=c43b12e05591818ba6882bfa1000504b


#9

Click only on the mobile icon, not the others. Make sure the mobile portrait is highlighted grey. If you need landscape off, click it too.


#10

The problem is when he disables the interaction for the mobile version, the div disappears.

I think the reason you want to disable this interaction is because on mobile, the divs take ages to come on to the screen. So, if this assumption is true you don’t need to disable the interaction at all. You just need to change the Offset value to 0%. Which is what’s causing for your animation to get delayed in the mobile versions.


#11

Okay then something’s incorrect because disabling an effect shouldn’t remove the Div at all.

@bonidom, try to reset the entire animation.

An entire Div doesn’t disappear if you only add the interaction for a device view.


#12

Not suitable that no one has ever encountered this?


#13

Sorry to hear it, but that’s technology, never full-proof for all. Never heard of an entire div disappearing unless you have a setting hiding somewhere. :neutral_face:


#14

Div block 22 has display:none in it’s main settings - could that be conflicting with the animations set, initial states etc ?


#15

I tried all the blocks, it does not work


#16

Block Div ​​22 does not apply to this topic at all


#17

On another site the same
https://preview.webflow.com/preview/powerbankjumpst8788?preview=040dd9567e39c2112a9d0f2af5bbbeb4



#18

http://web-64f692.webflow.io/

http://powerbankjumpst8788.webflow.io/


#19

Your original post seemed a general question, and other than a screenshot ref Div 4 i’ve not seen a specific div or divs that your are focusing on.

Rather than trying to locate every div you may have been referring to, I looked at 22 and saw what could be an issue if you had that same setting on any others with an interaction.

I’ve had a deeper look, and it does seem strange why it disappears. @cyberdave - are you able to spot anything amiss here?

A workaround could be this - to set another interaction on Div 4 - and select only mobile portrait for this - click new animation, and give it a state of opacity 100% as an initial state. Although not ideal, that appears to show the div successfully.


#20

on another site the same problem