Streaming live at 10am (PST)

Redirect loop when using cloudflare and strict SSL


#1

Two of my webflow sites are down:
LondonMortgageAdvisor.co.uk
BadCreditMortgageBroker.co.uk

with message in google chrome:
This webpage has a redirect loop

ERR_TOO_MANY_REDIRECTS

Both are hosted on webflow and run on https using cloudflare's free SSL service. My other sites which are also hosted on webflow but http only are ok, eg surreymortgagebroker.co.uk,

I've contacted cloudflare and they say:

//start of cloudflare reply

It looks like you have a redirect loop on badcreditmortgagebroker.co.uk", where HTTP connections point to HTTPS, and vice versa:

$ curl -vso /dev/null http://badcreditmortgagebroker.co.uk
...
< HTTP/1.1 301 Moved Permanently
...
< Location: https://badcreditmortgagebroker.co.uk/
< Server: cloudflare-nginx


$ curl -vso /dev/null https://badcreditmortgagebroker.co.uk
...
< HTTP/1.1 301 Moved Permanently
< Server: cloudflare-nginx
...
< Location: http://badcreditmortgagebroker.co.uk/
...

You will need to remove one of these redirects to allow the site to resolve.

The "londonmortgagadvisor.co.uk" domain appears to be down at the origin, and is not on CloudFlare:

$ curl -vso /dev/null londonmortgagadvisor.co.uk
* Rebuilt URL to: londonmortgagadvisor.co.uk/
* Could not resolve host: londonmortgagadvisor.co.uk
* Closing connection 0

I hope that helps, but if you have any questions or concerns please let us know.

//end of cloudflare reply

I havn't changed anything with these domains. They were working 2 days ago and went down yesterday.

Please could someone from webflow advise me asap as I need to get these sites up and running again quickly.

Many thanks

Graham

Here is my public share link: LINK
(how to access public share link)


#2

First step to resolving issues: Disable all SSL settings.


#3

Hi @GrahamCox, thanks for your post. This issue has been reported and I will post an update as soon as possible. Thanks for providing the detail, it helps very much! Regards, Dave


#4

Hi @samliew, in a way, that is true, disabling the cloudflare and the way the SSL is being used should correct the issue. Webflow does not yet support SSL, but it is coming soon. In the meantime, I have reached out to the team to see how we can help solve the issue.


#5

Hi @cyberdave and @samliew

Thanks very much for both your super quick replies. An update...I followed samliew's advice and in cloudflare I disabled full SSL and the page rules set up:

http://*badcreditmortgagebroker.co.uk/* Always uses https

http://*londonmortgageadvisor.co.uk/*Always uses https

And the sites came back up immediately. But obviously I would like them working with https. I emailed Cloudflare asking them to investigate but it sounds like you are aware of an issue at your end @cyberdave ? Can you clarify please.

Thanks a lot

Graham


#6

Hi @GrahamCox, yes, this has been reported, however I do not have info on what the root cause is yet. As soon as I have more info on the issue, I will update.


#7

Thanks a lot @cyberdave

Graham


#8

What I meant to say is, after disabling the existing settings, we can always set it up properly again.


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.