Streaming live at 10am (PST)

Remove 1.11.1/jquery.min.js


#1

The 1.11.1/jquery.min.js library is conflicting with an earlier version, 1.9.1.

I need to use 1.9.1 to run a script. And, as a result, I have to comment out the 1.11.1 one after I export. Is there any way to prevent the 1.11.1 one from being automatically included in the exported build?

This is being "auto" included in the export:

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>

Thanks


#2

HI,

you can add code but you cannot remove or edit part of exported code frowning
Solution: manual removing in html editor


#3

Hi @msmillie - since our frontend components (e.g. navbars, tabs, etc) rely on the latest jQuery version, it's probably not likely that we'll support choosing different version in the near future.

If you do end up commenting out the version that we include and use an older one, please keep in mind that it could break some Webflow JavaScript components.

Just out of curiosity, is there something in your script that is supported in jQuery 1.9.1 but fails in the more recent 1.11.1?


#4

Hi @callmevlad, I am experiencing a similar problem with my custom code. My custom code asks for jquery 2.1.0. If I remove Webflow's older jQuery 1.11.1 in order to get my custom code to work, would that affect Webflow's JavaScript components? Like @msmillie, I would very much like to have the ability to make changes to the Webflow's jQuery script as well, as I intended to host my website on Webflow. Now it seems like I must host my site elsewhere. :/


#5