Streaming live at 10am (PST)

Remove navbar interaction settings for mobile version


#1

Hi, I have created an interaction top nav bar when visitor scroll down the page, it will show and fixed at top of page.
When I doing the responsive version for tablet, I simply make it display none, but it will still show up when scroll down the page, how do I remove it's interaction at tablet version?

thanks


#2

Hey Bryan,

You can't disable interactions for a certain device/screen width so you're best off making a duplicate nav bar which is only visible on mobile devices and make your current nav only visible on desktop. It takes less than a minute to do and that way you can create separate interactions, or lack there of, for both.

There's a short thread on the same issue here: https://forum.webflow.com/t/how-to-disable-interactions-for-mobile-devices/23027

Definitely something to add to the WF wish list though.

Good luck!
UXM


#3

Thanks for your reply. I got this to work.


#4

Hi @Bryan_Ng

Instead of having multiple navbars which are more effort to maintain because you need to edit at least twice, how about leaving your navbar as is and insert a "pseudo" div. This pseudo div will get the interaction you want assigned to it and you just need to hide this one div on other viewports and the interaction will not show.

Best,
Karl-Heinrich


#5

Yes, this is a good idea, will try it, thanks.


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.