Streaming live at 10am (PST)

Repeat copy paste not behaving as expected


#1

We often need to copy paste an element several times: Divs, or list items…

So I hit CMD+C, and then CMD+V several times to duplicate.

We used to be able to just do this a number of times, fast and easy. Now if we do it, the element will not duplicate but rather do it once, and then paste it into itself (which is often impossible)


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Hi @Fagerlund,

Thank you so much for giving us the heads up on copy/pasting.

Currently, I am unable to reproduce the issue as you can see in the following short screencapture: https://cl.ly/858067693679

This definitely sounds like odd behavior, and I’m happy to take a look for you.

Would you be able to provide your Read-Only link?


#3

This is the same problem as mentioned here. While we are at it I’d like to know if a solution was ever found?


#4

You’ve got to copy, then manually select the parent container, then paste. The annoying thing is that they will then paste at the end, instead of in place, so if you’ve got a long list of things in the parent container you’re gonna have a bad time.


#5

These are exactly my words from that topic :slight_smile:


#6

But this is a general behaviour, not just in one project.


#7

Hi @Fagerlund,

We were able to speak with the engineers and noted that copying and pasting a node on the canvas using the keyboard shortcuts should create siblings of the originally copied node, and not children.

At the moment, they are looking into this regression to find a solution, though I do not have a timeline

Currently, the workaround would be to select the parent of the copied node, and then paste — this will create only siblings of the copied node: https://cl.ly/858067693679