Streaming live at 10am (PST)

Resolved: Custom nav menu bug


#1

Hi guys,

I have a strange issue, when set up the interaction with custom nav menu, when I click on dropdown, the custom menu icon keep closing & opening from the 2nd click, the 1st click is totally fine (see more in the gif).

How can I stop the dropdown to trigger the menu icon? Many thanks!


Read-only link:
https://preview.webflow.com/preview/nugit-618d31?preview=6f3beecc621d164b75154951962f6570


#2

Anyone knows how to fix? Please help :frowning:


#3

Hi,
I’m looking … and … I think I understand. Is the “Dropdown” component triggering the “Main Nav Button” when clicked?

Also, how did you create the hamburger icon animation? I can’t find it.


#4

Thank you so much for posting this @hoanggiang12 it looks like the dropdown animation trigger is causing the navbar open/close trigger to fire. I’m looking in to this with the team and will let you know as soon as I have an update!

Thank you so much for your patience and understanding as we work towards a resolution! :bowing_man:


#6

Hey man, its here :smiley:
34%20AM

Yeah, It happens only after the 2nd click, so weird


#7

:bowing_man: :sunglasses:
@Waldo is here, I know Im saved
Please let me know as soon as possibe!
Thanks a lot!


#8

Hi @hoanggiang12

Our team just pushed a fix for this :tada:

I tested on my end and it appears dropdowns no longer trigger hamburger menu animations.

Can you please test this on your end to see if it’s still an issue?

​Thanks in advance!


#9

Woo hoo! Thank a lot @Brando
It works well on my end too! :sunglasses:


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.