Streaming live at 10am (PST)

[Resolved] Duplicate Class, hit Return, BOOM


#1

I’m getting this repeating issue in Webflow when I duplicate a class and rename, if I hit the Return key to verify the rename, all divs which are scaled or affected with interactions (1.0 and 2.0) blow up to huge size in the designer window. They export fine, but I have to reload the browser window to reset them and allow me to continue working on WF.

Bugging the heck out of me this is… anyone come across this, or have any solutions/suggestions?

Thanks so much,

Steve


https://preview.webflow.com/preview/next-level-bikeshop?preview=587a2fdb92fa8e605f95af9c2e3dca4a


#2


#3

Yep. Sometimes if you go ahead and change something on the duplicate>save>refresh then at least the duplicated class stays alive. Sometimes not.

It’s easy to get this bug to duplicate. Not sure why it’s still hanging around for so long.


#4

It’s been happening to me as well. I just refresh the page.


#5

It’s been happening to me as well. I just refresh the page.

Which I do too, but (1) it’s not always bringing the fonts back, and (2) it’s a pain because every time you reload, it brings you back to the Home page and not the one I was working on, nor with the item I might have had selected at that time to work on…

Webflow Staff, any assistance possible with this?

Thanks so much in advance,

Steve


#6

Same thing, yeah. Annoying but not critical. Still would be nice to not have this at all.


#7

Same thing, yeah. Annoying but not critical. Still would be nice to not have this at all.

Agreed…


#8

Just realized all this bug does is enables “show empty elements” control. So no need to exit-enter designer, just uncheck this in the lower left corner.

edit: also, after you do it once all subsequent duplicates will work without the bug!


#10

Hi @energidesign @jdesign @dram @Cricitem

Thanks so much for posting about this!

I agree that this bug is definitely annoying—I’ve notified the team of the additional instance and info provided here and we will continue to investigate.

I’ll post back here as soon as I have an update for you all!

​Thanks in advance for your patience :slight_smile:


#11

Hi @energidesign, @Cricitem, @jdesign, @Anton_Lyutikov, and @dram

We pushed a fix for this issue with duplicating classes.

Everything should work as expected after refreshing the Designer.

Can you please confirm that the issue is resolved on your end as well?

Thanks in advance.


#12

Confirmed, works as intended.


#13