Streaming live at 10am (PST)

[Resolved] Err_ssl_protocol_error


Hi guys,

I am trying to connect a client’s Domain to a Webflow page I built. They used GoDaddy as the Domain provider; I updated the CNAME as needed by webflow. Also, webflow is saying that everything is connected (see image).

Yet trying to access the website gives me the browser error: ERR_SSL_PROTOCOL_ERROR

Does anyone know how I can fix this?!

The page is




Hi, I’m having the same issue. I just tried to visit my site and I get the same message. Need to get this site functioning tonight for a marketing event tomorrow!


@Douglas_Fllrtn We had a temporary issue with our downstream provider issuing new SSL certificates, but it should be resolved now. I’m able to load successfully.

@csdsja18 Could you please try reloading? Or include your domain name so we can investigate? Thank you!


Perfect Vlad. Thanks!


It’s back! Thanks so much Vlad, and Doug for starting the thread.


I’m facing the same issue. Returning ERR_SSL_PROTOCOL_ERROR for

DNS Seems to be fine: and - showing as connected in the Webflow hosting dashboard.

Is there a solution for this @callmevlad?


Hi @tomwye, there is a similar issue and out team is working to get that resolved, I will notify once that is updated.

Thanks in advance.


Hi @tomwye, I was checking and on the domain is showing records for both the and servers, could you please remove the cname record?

After doing that, check the site again.


@cyberdave thank you! I had disabled the SSL in order to try and get the site online. Re-enabled and all seems to be working now. Was it an issue Webflow side or ours?


Hi @tomwye, thanks, there was an issue with our downstream provider with the SSL certificates, it affected to a small number of projects. The issue is now resolved.

I hope this helps.


We have the same problem with our website:
Could you please check?


Hi @eftz

It looks like this is a separate issue — sending you a DM with the details :slight_smile:



I just updated my settings for SSL and I’m getting the same error at

Are you still having issues with your provider?


Seems to have updated, so all set!


Oh, awesome! Good to hear!

Yes, it does take a few hours for DNS changes to propagate :+1:


Hi this seems to be broken for That said and both work.


Looks like is working now :slight_smile:


I have this problem with works ok, but without www. it doesn’t.

I did disable and re-enable SSL already but with no result.

Unable to add CNAME for .app domain


Looks like is redirecting as expected now :+1:


Hi, I’m having the same problem with my website “”. ERR_SSL_PROTOCOL_ERROR

could you tell me how to fix it?

thank you in advance!