Streaming live at 10am (PST)

RESOLVED: IX 2 performance issues and SVG not uploading


#1

Hello webflow,

Since 2 months I I have been working on webflow very often (to make my own website), and I noticed that Chrome was becoming more and more unstable. I have been looking online, and It seems to be happening to different win10 pro users, but I suspect all my problems to be linked.

Config:
Windows 10 pro 64 bit
Build 1709 - 16299.64
Intel® Core™ i7-6820HQ
ThinkPad P50
Latest Chrome version

So this topic cry for help if anoyne already experienced the same issue…

1. Chrome crashes right from the start, cannot be open.
I can only open it as administrator, and when it opens it ask to re-open the tabs that were closed, because it think Chrome had crashed before (while I just closed it normally).

2. Webflow becomes extremelly laggy.
Moving around panels, especially the new interactions is hell.
So I am forced to close and restart the browser. It comes down to 10 min of clean workflow, closing, another 10min etc…

3. Unable to upload content.
SVG especially, or impossible to drag and drop.

4. Webflow randomly crashes.
The whole software turns white and grey.

Needles to say that I have done many re-install and reboot and scans…
At first I thought that was the webflow extension that caused the problems.
But even after removing every extensions it stills does the same issue.

A similar issues also happens on OpenOffice, the software bugs and thinks my previous file had crashed, so it is stuck trying to recover a non existing file.

Which puts me into questionning if that’s a Chrome issue, or a windows issue?

Thanks a lot.


#2

Hi @Okidoki,

Thanks for posting this, these issues definitely sound like odd behavior.

2. Webflow becomes extremelly laggy What site are you seeing this issue occur in? When did it start occurring? Can you send me the site Read-Only links please?

Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: https://support.google.com/chrome/answer/95464?hl=en
(2) Try to reproduce the behavior on a different machine and network connection
(3) If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console

3. Unable to upload content: Are you using an on line converter to convert PNG or JPEG into an SVG? If so this may be the issue. Please check out this post for more information on how “fake” SVGs can cause issues.

Can you send me a copy of the SVGs you are trying to upload? What project are you trying to upload the SVGs into?

4. Webflow randomly crashes: What actions are you taking when the Designer crashes? Can you provide a list of repro steps?

Can you please try the following for this issue as well:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: https://support.google.com/chrome/answer/95464?hl=en
(2) If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console

1. Chrome crashes right from the start, cannot be open I recommend contacting Google or Windows support as this falls out side our statement of support.

​Thanks in advance, and I’m standing by for your reply.


#3

Hello Brandon,

Thanks for your extensive reply, and willingness to help.

About the different point:

1. Chrome crashes right from the start, cannot be open.
After reinstallting my graphic card, it seems that the Chrome crashing issue has disappeared.
As on my laptop I have 2 graphic cards, I suspect there was a conflict happening somewhere.
I have an Intel ® HD Graphics 530 and an NVIDIA Quadro M2000M.
Do you know anything about this?

2. Webflow becomes extremelly laggy, freezes, get stuck
This is still happening, even in incognito, and it is happening mainly on the new interactions panel.
I click on an element and I have to wait 10s for webflow to be working again to change the parameter.

Site
Please especially check on the home page the scroll interaction, this is by far the worst.
And Also the first logo animation. Basically what happens with this one is, I can’t even work on it anymore, webflow freezed whenever I try to reopen it.

Is it a because my website is too heavy of things? (maybe that’s the whole point), or is it because the new interactions are too heavy in general to support? If this is linked to the content of my website, then this is unfortunate for me, because I wanted to make it this way. Otherwise that would mean that the new interaction are too complex or too heavy to work with on my laptop, and I think that’s a big down for me.

I am even considering stopping using the new interactions even…
I did do a test on a deskptop computer, and it was smoother, but still not ideal.

Is there somewhere a guide on the do’s and don’t with interactions and webpages content? When do we know that it is over loaded? How can we optimize the website?

Can you scan my website with some software and tell me if it is too heavy, or what are causing those massive lags?

3. Unable to upload content.
I turn files into SVG in Illustrator, some are really light in weight, some are heavier, I am still looking at ways to optimize those. Are SVG creating a lot of memory brower issues where there are too many, and some complex?

4. Webflow randomly crashes
Thanks for the tip on the console, I will try to remember copy paste those. As I am not sure what cause the problem. Basically these all happened when I was working for an extensive long period of webflow without shutting down the browser, and when I started editing css properties or playing with interactions the whole panel frozea and turned white and grey. For example, doing Ctrl+Z 5 times in row.

Many thanks!


#4

1. Chrome crashes right from the start, cannot be open.
I do not know about any issues with Chrome and these graphics cards. I do know that Chrome sucks RAM like crazy though, so if your laptop doesn’t have much memory this could be affecting Chrome and more specifically the Webflow Designer.

2. Webflow becomes extremely laggy, freezes, get stuck
I took a look at your project and it does look like you have a lot of assets. Are you using every one of these? If not I strongly recommend deleting unused / duplicate assets as this is probably the main source of lag. I noticed some of the images are considered very large which is also adding to the lag. While we allow up to 4mb image file size, we typically recommend keeping them under 300kb.

That said, I also looked into your interactions and experience the same lag you mentioned. This definitely looks like an issue associated with the interactions themselves. I’ve reported this to the team and will get back to you as soon as I have more information on this.

3. Unable to upload content
This sounds odd for sure. Can you please provide more information? Can you send a screenshot/ recording of the behavior? Can you also please take a screenshot of the console when an SVG fails to upload?

4. Webflow randomly crashes
I tried reproducing the issue but was unable to. Please let me know if you encounter this one again.

​Thanks in advance, and I’m standing by for your reply.


#7

Hello again Brandon,

Many thanks for your kind help and willingness to find solutions for me!
I will answers your points right away.

1. Chrome crashes right from the start, cannot be open.
The Chrome crashing is solved apparently, but it seems that the RAM is indeed the problem. My laptop has 48G of RAM, and it runs perfectly fines on most of my softwares ( the classico Adobe Suite all open at once). But, once it is on Chrome, and on Webflow (my website), ho god… Even here at the agency where I work, on their computer, working on Webflow is still laggy and the website freezes. See picture for the computer specs, it is a bit smoother than on my laptop, but still working with I.X 2 is complex now.
36

2. Webflow becomes extremely laggy, freezes, get stuck
I am going through all of the assets at the moment to deleted most of the unused once. We shall have, in the designer panel, an icon showing the un-used assets and be able to checklist them.

Interesting bug:
Could you check my home page again, and see that the content under the first project “Oedipus Brewing” just disappeared of the Desktop and Ipad view, while on the Mobile views it is there, visible and functioning well. It seems the whole content of my div is set to Hide… but looking at the interactions and CSS panel everything looks alright.

It all comes done to Interactions 2.0.
Do they interfere or conflict with the Legacy Interactions?
Or, because of their complexity, they just totally snuff out Chrome, and thus, Webflow, from the RAM?
Meaning by that, that it is wiser to reduce their use to 1 max per page?

3. Unable to upload content
This problem seems to be gone, but it does somehow happens when Webflow lags, or Chrome is overrun by the amount of informations.

4. Webflow randomly crashes
It looks like those issues are gone, but it seems that they are all related to Chrome being laggy and sucking up RAM, as if, the browser is unstable.

Thanks again for your help.
Waiting your reply and the team about my issues (I am probably not the only one with that).
OKi


#8

Hi @Okidoki

Thanks for the extra info!

Glad to hear 3 and 4 are resolved — keep me posted on if you see those behaviors again and know how to reproduce them.

For issue 1, we have an open report for the team to investigate performance improvements around interactions 2.0 — specifically when it comes to animation heavy interactions that involve many elements.

For issue 2, I took a look at you project in the Designer and webflow.io subdomain and was able to see the “Oedpius Brewing” heading as expected:

Were you able to resolve this?

​Thanks in advance, and I’m standing by for your reply.


#9

Hey Brando,

Thanks again for the quick reply.

Issue 1 : I cant wait to hear the team investigation on that. I am eager to know if my website is a behemot with too many things, or am I reaching the limits of Chrome?

Issue 2: Well, also I found my mistake there… Anyway on this one problem solved.
But if you are curious, and this will link to issue 1, open the interaction on the logo below the header, and see if you can access its properties. Because for me, it totally freezes my webflow. This interaction is sort of in a dead end, I cannot access it anymore, nor change it…
Here is the way to get it: Wrapper Logo > Container Logo > Boite Logo Oedipus.

Please tell me, if like me, opening this interaction totally freezes your webflow.

Thanks so much!
Okidoki


#10

Hi @Okidoki

Thanks for letting me know!

The performance issue you are experiencing isn’t due to the size of your project. It looks like there are some performance issues around the many elements included in one animation.

The logo you mentioned is one such interaction. Our team is still investigating this and hoping to have it resolved soon to prevent any more performance issues for you.

I’ll post back here with an update as soon as I have one!

Thanks again for your patience and help with this issue.


#11

@Okidoki

Thank you again for reporting the performance issues.

Our team was able to push a fix for this and your project should run much faster now around the interactions.

Can you please check refresh the Designer and test this on your end?

​Thanks in advance, and I’m standing by for your reply.


#12

3 posts were split to a new topic: Interactions 2.0 issues when working in symbols


#14

Holy hell, the IX2 is now waaay faster. No more click, wait 3-4 secs, modify attribute in complex interactions!


#16

@Okidoki

Thanks for the update and letting me know about these other issues. Happy to hear issues 1 & 2 are resolved.

As it seems the original issue in this thread has been fixed, I’m going to mark this thread as resolved and break off these new issues into a new post.

:slight_smile:


#17