Streaming live at 10am (PST)

[RESOLVED] Nav Appear flickers as you scroll Help


#1

I followed this tutorial:

Nav Appear as You Scroll

Very good tutorial. It worked wonderfully at first but eventually it broke. Sometimes it works and sometimes the nav bar just flickers "on" then hides and does not reappear again.

If I preview the site within webflow it always works. The problem presents itself when simply opening the public link.

I thought I fixed it once by simply deselecting and reselecting the interactions, but it happened again. The latest big change was making the whole header with it's slideshow fixed for a parallax effect. So I figured being fixed meant it got in the way of the scroll out of view trigger, so I moved it to my header container which does scroll away (where the logo is).

It did not fix it and I am launching the one page site on Friday, please help!


#2

Can you please update your post so it's easier to understand your issue and help you?

Please consider:

  • giving us you projects' sharing link (see how below)
  • tell us on what page, and what element you need help
  • add a commented screenshot of the issue, and a sketch of how you want it to look, if needed

You can find detailed information about this here too: http://help.webflow.com/sharing-your-public-webflow-site-link


#3

Thank you @vincent I rushed through it and forgot to do so!

Sharing link: https://preview.webflow.com/preview/picnicdepalabras?preview=dbfd8d12f170a9dc2590514291321004

The website has only one page, the issue described relates to the menu's behavior. The interactions applied are on the Nav Bar and on the very first container (Hero Section), more details on the first message.

Thank you !

Screenshots:
If I preview the site, the menu should appear after scrolling past the hero section, but it does this only part of the time. Even when it does happen, after scrolling up and down again it slides up/flickers and disappears.
.
.
Menu that should appear upon reaching second section

However, it often does not. Sometimes it does though.


#4

Update:

Fixed it, the scroll hide/reveal action had been accidentally assigned to a couple of elements within the menu itself and caused the flickering effect and constant hiding of the menu.

Having found the first such instance by accident (using the up / down arrow keys) and then consciously searching for any further instance and deleting it, the issue appears to be fixed!


#5

Ok, great, sorry, was the weekend (: Have a good day.


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.