Streaming live at 10am (PST)

[RESOLVED] Problem with white space showing on right hand side of page


#1

This happens on most of the sites I create with webflow. I'm getting a white bar on the side of my pages and not sure why.

Can anyone figure this out?

https://preview.webflow.com/preview/jordans-portfolio?preview=1a419e7ff6d8880ac3e8d8cbc8a229ae


#2

Any insights @Waldo?


#3

Hi @TriceWD,
let me help you.

You have "skill txt" elements moved on 60 px to the right side by using relative/absolute positioning settings and it is what cause the "gap" on the side.

I suggest using left padding for this elements and it will fix the problem. Or apply overflow: hidden to the "skill-column"

Regards,
Anna


Site on mobile device in portrait view is not full width
#4

That worked!

Such a simple solution, but not so simple to find.

May I ask how you figured this out so quickly?

(Much appreciated by the way, thank you for helping me out again - I didn't forget about the last time :heart_eyes:)


#5

:smiley: You are welcome

For finding the reason of overflow (it is what cause gap on the site) I usually open the live/published site in the browser "code inspect" mode, make it shown in mobile view and then step by step go to add overflow: hidden to every big sections CSS settings. When one of the section react on this (gap disappears) I remove overflow: hidden from the section CSS and do the same with elements (rows, divs, etc.) inside the section. When one of the elements react - I am going deeper :wink: Logic behind the magic.

Cheers,
Anna


Site on mobile device in portrait view is not full width
#6

Neat way to pinpoint exactly which element is the problem.

Thanks Sabanna!


#7

Hey @sabanna

Just wanted to let you know I've been using your method to solve this issue on multiple projects here.

Super helpful and super useful.

This is STILL much appreciated! :smile:


#8

"Give a man a fish, and you feed him for a day. Teach a man to fish, and you feed him for a lifetime."
:wink:

Always welcome, glad it works.


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.