Streaming live at 10am (PST)

Responsive design doesn't work


#1

Hi, these are my details:

fisker-it.webflow.io

I am having troubble making text boxes, paragraph and other icons responsive when I slide the PIN to make the page thinner and wider to fit iPhone 6 etc. The text doesn't seem to get fittet for the page size. They start out being responsive and then they stop after i have classified them. Or thats a teori I have.

Right now I am working on the site: SUPPORTPAKKEN - some of the site is responsive and the one I have edited is not.

I hope you can help me. Thank a lot.


Here is my public share link: LINK
(how to access public share link)


#2

Hi @VFJ99 Could you please update your post with some more information so we can help you faster? Things like your read-only link & screenshots really helps us to help you faster :slight_smile:

How to share a read-only link:
https://help.webflow.com/article/how-do-i-share-my-sites-read-only-link

Thanks in advance! :smiley:


#3

https://preview.webflow.com/preview/fisker-it?preview=926df436f8a87c40a9550e4eef4c5d4f


#4

How do I make the text boxes responsive in Phone view on the page: SUPPORTPAKKEN. It seems only some of them are responsive when changing the Phone view (iPhone 5 to iPhone 6 etc)

Hope someone can help. Thanks a lot.


#5

Hey @VFJ99

I see that you are having fixed dimensions for most of your wrappers. In most cases, it's best to set the width and height of a wrapper element to auto or %. Setting it to auto or % will make it adapt to the width or height of the page no matter the screen size. Setting it to, for example 80% will make it fit 80% of the page. In your case you are using pixels (px), if you're using pixels for height or width the element won't adapt to the screen size as it is a fixed width.

For example:
You've set the row element on the top of the page to width 1134. This element will now always be 1134pixels wide and it will never change its width to the screen size.

I hope I was able to clear some things up.


#6

Hi Dharma, Thanks a lot. That did it! You saved the day... week :smiley:


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.