Streaming live at 10am (PST)

Responsive slider not responsive?


#1

Hi guys for some strange reason the slider is not being responsive.

I have a slider and the height is set at 1080px when I size the browser the slider stays the same height and does not gradually get smaller. The closest I have got modifying settings is the image gets smaller but the slider stays the same big size.

Any help will be really appreciated

Thanks


#2

you need to change the size of the slider object for each media query (Desktop, Tablet, Mobile)


#3

Hi thanks for the reply.

I have selected the different media queries on the left and changed the height of the slider from auto to a smaller pixel size but it does not do anything, I have also tried to change the size on the slide as well same thing.

I know im being silly I just cant work it out.

Thanks


#4

bump
2 hours later and I still cant work it out frowning


#5

I really need help, I have gone in and tried to change size for every media size. It just does not work correctly. Do I modify the size on the main slider or the individual slides? I change the sizes on the different media sizes n the main slider and it looks good. When I preview and scale down the browser, the image does not reduce in size until the next media query where it suddenly jumps to a smaller size.

Could someone please tell me what I need to do I will really appreciate it smile


#6

@cras111 With the slider, it is usually best to change the height of the outer "Slider" element.

However, if you prefer- you can set the Slider height to "auto" which will cause the slider to inherit the height of the tallest content within the slides.


#7

Hi thanks for the reply I have changed the height on the top slider element but when I change the web browser slze the image changes size in width NOT width and height.

Other sites I have seen on Webflow the slider changes size like it is being made smaller on the diagonal and keeping the aspect ratio but making the width and height smaller at the same time.

How do I achieve this?

Thanks


#8

I wanted to paste the link to my work but it wont allow me to paste. I have a feeling there are some bugs as I look at the preview now and no slide bg image is showing at all frowning It shows in the editor but not in preview or publish.

Plus I still cant seem to get this slider responsive!!!!!!!

How many hours now?

Ive tried everything


#9

How is that it won't allow you to paste? Who? Where?
Without the public link it's hard to help you.


#10

I sorted it after many hours smile

My bad I have just seen the info for copying live site as a link

Now to try and port it to WordPress frowning
Thanks


#11