Streaming live at 10am (PST)

Rich text glitches


#1

Hi Webflow,

I’ve noticed in recent months that Webflow has been getting very glitchy. It would seem your efforts are concentrated more on new features and less on maintaining the quality of the old ones.

I’m becoming a little frustrated when trying to use the Rich text in particular.
Firstly, copying and pasting text (I do this a lot as I make websites in 2 languages) creates about 5 line breaks above and below the pasted text. Then it starts glitching out constantly.

A few examples:

  • deleted paragraphs reappear
  • cursor jumps around to a different part of the text for no apparent reason
  • weird boxes appear that you can’t delete
  • entire sections of text being formatted as headers and you can’t change it

There are lots of other similar glitches and it’s becoming really difficult to be efficient in Webflow. Hoping you guys will look into it because it’s been going on for months now.

Thanks


CMS Rich Text errors in Editor when using Safari for macOS
#2

Hi @cjeancouture,

We’re currently in the process of a complete rebuild of the core text editing functionality across Webflow and have been gradually rolling it out and fixing issues. Currently the designer-canvas is the only place using the new version.

Some of the examples you listed are things we’ve fixed, although it’s possible there are edge cases or regressions we missed that we’d want to prioritize fixes for.

We’re currently aware of some line break paste issues but so far they all seem to be related to the source content being copied containing extra line breaks. Ideally we’ll come up with an improved universal way to detect when they’re unwanted and clean them up on paste.

If for any text editing issues you’ve run into you’re able to share:

  • repro steps
  • which browser/OS you’re using
  • and where in Webflow you’re running into any of these issues (designer-canvas, data manager, editor-canvas)
  • bonus points for screenshots/screencasts

Our ContentEditor team can prioritize them

Hopefully as we work through the known edge case list the new Content/Text Editing system we’re building will be a lot more stable and less prone to bugs than the old system.


#3

Hi @cjeancouture,

Thanks you so much for your patience!

Our team was able to isolate the root cause of the issue and we’ve pushed a fix for this. It may still take some time to fully deploy, but the issue should be resolved this afternoon.

Can you please let me know if the issue is resolved on your end?

Thanks in advance, and I’m standing by for your reply.


#4

I’m glad I’m not the only one who noticed this. The issue is still occurring for me. Text that is copied and pasted is extremely glitchy. Reappearing paragraphs after deletion, words NOT deleting even though the cursor indicates it so, multiple line breaks, etc. It’s quite horrible with Rich Text and not client friendly. This is happening both in the Designer and the Editor.

I would love an update on this.


#5

A post was split to a new topic: Editor issues and conditional visibility questions


#6

Hi @cjeancouture

Just wanted to touch base with you here as there is more than one issue you mentioned in the original post.

What we’ve fixed:

  • The fix @Nita mentioned is for the extra line breaks appearing above and below pasted text – that issue has been resolved.

  • We’ve also pushed a fix for an issue where the cursor was jumping around. This was happening in text fields when editing a collection item


Other issues

Deleted paragraphs reappear – Can you please provide the additional information Yoav mentioned?

  • repro steps
  • which browser/OS you’re using
  • and where in Webflow you’re running into any of these issues (designer-canvas, data manager, editor-canvas)
  • bonus points for screenshots/screencasts

It’s also helpful to know where you are seeing this behavior – Editor UI, Editor canvas (i.e. on the page), Designer canvas, or data manager (CMS collection).

Weird boxes – this sounds like styles or unique symbols are being pasted from a separate application. Can you please make sure the content pasted doesn’t have these symbols or styles associated?

It’s also worth mentioning here that we aren’t able to reproduce these issues on our end so the more information you can provide here the better we’ll be able to help find a fix.

@arbowe thanks also for posting. If you are able to shed some light on these issues too the help is very appreciated :bowing_man:

​Thanks in advance!