Streaming live at 10am (PST)

Rotate on Mouseover not working in Live Preview


#1

I’m trying to do a very basic rotate on mouseover. It works fine when published, but not in live preview. Curious what I’m doing wrong.

https://preview.webflow.com/preview/scratch-93f451?utm_source=scratch-93f451&preview=a2757ab44ae6f01517ec47ebc1f643be

LIve link: http://scratch-93f451.webflow.io/

I’m using the latest version of chrome on a mac running 10.13.6 High Sierra.

Here’s a screencast: https://cl.ly/4aea3590b41f


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#3

Hi @Jason_Gaylor

Thanks for posting about this interactions issue.

Curious what I’m doing wrong.

You aren’t doing anything wrong here — this looks like a bug affecting the live preview for mouse over interactions. I was able to reproduce this and I’ve reported the issue to our interactions team. We’ll dig into the root cause here and I’ll post back with more info when I have it.

​Thanks very much for finding this!


#4

Any news on this?

I’m having the same problem.
However - it just got worse and now I can’t turn the Live Preview mode on at all.
Interactions don’t show at all on the front end

https://cl.ly/5ba3f486615a

I did have the rotate interaction working an hour ago but for some reason it wasn’t rotating - it was shrinking and enlarging.
Now nothing.

Using PC Win 10 and the latest Chrome.


#5

Hi @dollhauss

No updates on this yet.

In the recording you provided, though, it looks like the interaction has been disconnected from any element or class. If you right click the rotate animation, you can choose Change target and select the element. Once the animation has been bound to an element/class the live preview should activate as expected.


#6

Cheers @Brando

I added the rotator block as target and it’s kind of working.
Just a jittery mess tho I’m afraid.

Check it out:
https://cl.ly/dcce6a767b71


#7

Hi @dollhauss

Happy to see the live preview can be enabled now. Also thanks for the great videos — definitely helps to visualize the issue!

The team is still investigating a fix for the glitchy key frames. I’ll post an update here when I have more information :bowing_man:


#8

Great stuff,

Cheers @Brando!

Do keep in mind - that if you check my video, you will see that the rotate transition does not rotate.
It shrinks and enlarges instead.

And this transition does not work on the published site either.

Thanks mate… Look forward to this being fixed so I can use interactions again.


#9

the rotate transition does not rotate. It shrinks and enlarges instead.

It looks like the div is rotating, but is doing so along the Y axis so you are seeing the expected behavior (makes it look like it’s shrinking). Try rotating it along the Z-axis and you may get the behavior you are expecting :slight_smile:


#10

Cheers @Brando

I’m following this tutorial video of yours.

When copying the settings in the video - nothing happens.
Apart from a bit of glitchy stuttering.

Very confusing.


#11

Hi @dollhauss
Can you share a Read-Only to your project? It’s hard to say what is causing the glitch without seeing the settings for your site :slight_smile:

thanks!


#12

Sure @Brando

All that is on this is a section with a div (called rotator) using the basic interaction settings mentioned as the video begins.
https://preview.webflow.com/preview/test-75791c6385fabfbe7fcf6c86145?utm_source=test-75791c6385fabfbe7fcf6c86145&preview=bd02133059cbd9956944d42079fdce19

Cheers