Streaming live at 10am (PST)

Same interaction works on most of the pages but doesn't work on few others


#1

Since I’m posting glitches today, I also want to reminded about another bug I reported before, which still persists.

Here is my project share link

The navbar should be semitransparent on the contact page and only become solid upon scroll, it works perfect on this page for example: https://www.rogercastillo.org/subscribe

This is just same interaction with replaced class and it works on each page, while Donate page is the source of interaction, however on the contact page and maybe some others it doesn’t work properly,

I know that class replacement is a legacy feature, however even If I recreate a new interaction from scratch with the same logic, it still doesn’t work on the mentioned pages

It just jumps to 100% even in the preview mode…See video


#2

And also another glitch in the same project on Events Template page.

I have two different Hero divs there, one is taking the “large image” from the CMS, and if that image is not set another default image is being displayed.

So on all pages where the “large image” is not set I have this glitch: when I’m scrolling page to the top very quickly the navbar is being wrecked.

See the video on that one

This bug happens only in Safari, the first one above happens in any browser.

Sorry I keep posting bugs, but really wanted to nail them for a long time :slight_smile:


#3

Hi @radmitry I think the issue is that you have a while scrolling interaction set up. On the subscribe page this works because you have enough sections to scroll through. On the contact page though, there isn’t any room to scroll so the navbar is automatically set to 100% opacity. If you open the inspector you can see the interaction works as expected because there’s now enough space to scroll: https://cl.ly/1o1t1n2P381B

I recommend adding another section to the footer so there’s a scrollable area, or maybe tweaking your interaction slightly.


#4

Hi @Brando , you are of much help again!

Good to know what caused it, redesigned using a hidden trigger element and scroll into view interaction.

Thanks! :relaxed::webflow_heart:


#5

@Brando Redesigned my Events template in a same manner and moved nav-solid element out of the navbar on that page and the second issue is now gone too!

Whoohoo, thank you very much. :stuffed_flatbread: :cup_with_straw:


#6

That’s awesome! I was looking into that one but was stumped — happy to hear it all works :man_dancing:


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.