Streaming live at 10am (PST)

Samsung Galaxy S7 not displaying site correctly


#1

Just published my first website.
All the pages come up fine with the exception of the banner page, and ONLY on my Android phone (Samsung Galaxy S7 - Chrome which is up-to-date).
It works well on my 2 computers (using Safari and Chrome), my iPad and my friends iPhone.
I have re-viewed the mobile phone settings and in view mode the site transitions through the different phone sizes without any problems.
Do you have any suggestions as to why it isn't translating to my Android phone properly?
I have attached images of the issue one from my phone and two from preview in Webflow in different size configurations for mobile phones.


#2

Have you checked if it's on fire?

(... sorry, couldn't resist)


#3

I hope not. It is just the banner page and it seems to offset the text. I tried it on two non-incendiary Android phones with the same outcome.


#4


#5

Hi @noel_jago123, thanks for the question, could you also share the site read-only link so that it is easier to check the styles that are on the page? http://help.webflow.com/faq/how-do-i-share-my-sites-read-only-link

Thanks in advance!


#8

https://preview.webflow.com/preview/functionalhealthmt?preview=090ada4374df7c3b448d7f60714e80ef


#10

I was wondering if you had any suggestions. I have, again, looked at the site on friends a friends iPhone and it works wonderfully. It just seems to be with Android devices so I'm at a loss.


#11

Hi @noel_jago123, take a peek here:

I hope this helps!


#12

@cyberdave , is that BrowserStack?


#13

Hi @seank, yes, that is browserstack which I am using for the testing and page inspection on mobile devices.


#14

Awesome.. i thought so. I use them too and I highly recommend them to everyone - great tool.


#15

Dave it worked perfectly. Thanks so much for your help. Much appreciated.


#17

This was really helpful.