Streaming live at 10am (PST)

Scroll Interaction


#1

I have created two interactions, one that affects the logo, and one that affects the heading. however I can't have them both active at the same time. Why is that? That's really annoying.

Also, why aren't the interactions responsive?


#2

Hi,

Only one interaction can be active, however one interaction can have multiple triggers, effecting different elements in different ways. Try adding multiple triggers to an interaction.

Could you elaborate on what you mean by;


#3

What I mean is, I created this interaction that looks really good on desktop, and horrible on mobile. I can't seem to disable the interaction on mobile, or modify the interaction on mobile. If I modify the interaction in mobile view, it messes up on desktop.

Look at http://jameswelbes.webflow.com/ on desktop, then look at it on a tablet, or mobile, you'll see what I mean


#4

Hi @James_Welbes, it is not possible (yet) to disable an interaction on mobile. If you have this kind of situation, I would consider making a duplicate of the element that is having the interaction, then on the duplicate copy, and make it so the duplicate is only visible on the mobile viewports of your choice. On the original element with the interaction, make that visible only on Desktop. On the duplicate of the original element, the one that is shown on mobile viewports, simply remove the interaction from that element so that it does not run on the mobile viewport.

For the disabling of the interactions on mobile devices feature, please submit it to our Wish List and we'll notify you if we make it smile More info on our Wish List here: http://forum.webflow.com/t/about-the-wish-list-category/6464.

I hope this helps, let us know how it goes.

Cheers, Dave


#5