Streaming live at 10am (PST)

Search not showing any results

#1

Hi there,
I am new to Webflow, I have a project that I have setup for my client. Due to a confidentiality agreement I can’t share any files. The problem I have is that I cant seem to get search to propagate - I have been trying the search bar over a few days and nothing - the only thing I can think of is that I have put a password on my site - not sure if this would hinder search - at the moment the site just has h1 headings on different pages - I would have assumed these would show up in the search for keywords? Any troubleshooting tips would be welcome - happy to discuss this with Webflow staff for actual file previews.

#2

I could be wrong on this, but I believe search only works on hosted sites. Have you added hosting to this site yet?

#3

hi Brandon many thanks for getting back to me - yes it is a hosted site - and I have paid for CMS - I am using the prototyping website on a domain I am hosting with a2hosting -

#4

Search only works with webflow hosting, not exported sites. It is unclear to me what you are actually doing here.

#5

Yes I know this - My domain is connected with Webflow - I have not exported the code as such

#6

did some more testing on this - definitely a Webflow bug - I just setup another CMS plan and search worked out of the box - I was able to manually index the search and all the results worked - on my original site which I have been working on for a client this just doesn’t work -the manual index option is not selectable at all - yet its a CMS plan -

#7

I reported this issue to webflow - and they have fixed it - it must have been some obscure bug - so all good now search is working great on my site