Streaming live at 10am (PST)

Search results showing excluded pages


#1

Hey Webflow’ers,
I have been creating an info section using a CMS collection. I have placed the collection on multiple pages filtered via fields within the collection. I have placed a search bar at the top of the list in order to be used to search the CMS for information. I have unchecked every page and collection template pages except for the information collection.

exclude
The issue I’m having is that even though I have checked the checkbox and followed the instructions above, the results of pages that are checked to be excluded are still showing up in my results.

For the moment I only have dummy content in the collection so when I try searching for the term “question” due to none of the CMS items having that in them should produce no results but instead shows me results from other pages.

Hope that someone can shed some light on this bug/flaw/issue

Cheers in advance,
Ben
Page: https://www.expresswastewater.com.au/septic-systems/info
Share Link: https://preview.webflow.com/preview/expresswastewater?utm_source=expresswastewater&preview=e1c995d91a568a41f0fb2185f8d9787b


#2

Hi Ben, quick question. Did the index exist for that page already and then you excluded it? If so how long did you wait?


#3

Hey Jeff,
Yes, they did and have for a while now. The new info section is approximately 2-3 days old. I reindexed the website again yesterday and waited untill today to retest to see if it changed as that is whats recommended. But no dice, unfortunately.


#4

Sounds like you are doing all the right things. I think a staff member will need to chime in as only they would have visibility on search internals / indexes.

You may want to open a support ticket, instead of waiting for a response in the forums. I would.


#5

Ok will do, thank you for your response. I didn’t think to use support… Sometimes the most obvious of things are overlooked

Cheers again