Streaming live at 10am (PST)

Searching a website without "www"


#1

Hello, we are new to this. We have a website www.snowglobewhistler.com, but it does not work without always typing the "www" in front. How do we change it so people can just search "snowglobewhistler.com"? We used Go Daddy as our host. Thank you in advance.


#2

You'll need to add a CNAME record at your registrar, with the text "www" and pointed to your domain snowglobewhistler.com


#3

Hey @Snowglobe great to see someone from BC, I will be moving out there this week smile
.
Dealing with URLs and the way they appear is a server side issue. Usually dealt with in the htaccess file. The best thing to do would be to contact GoDaddy support and ask them the process for removing the www. from you URL.

You can try something like this in your htaccess file.

 RewriteEngine on
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1%{REQUEST_URI} [R=301,QSA,NC,L]

I do suggest contacting GoDaddy make sure there isn't something special you might have to do for it to work on their servers.

Edit: I think I misinterpreted your question. @jordanshotwell has got it right.

Alex


#4

Thanks all, think it's working now. smile


#5

I did take a look at the snowglobewhistler.com domain and your A Records are correctly pointed at Webflow, but you still have one A Record pointing at Go Daddy. Go remove that one, see my screenshot:

Update that, then republish your site in Webflow.

​I hope this helps. If not, please let me know – I'm happy to assist further! smile

Cheers,
Dave


#6

Hello.
Well, I have 2 major problems.

We were able to access our site by typing in snowglobewhistler.com (not using the www) but it is no longer working. No idea why this would happen?? So, I re-did the CNAME as per instruction, but now it appears that the entire site is not working. It says it takes 48 hours to update (on GoDaddy) but are you able to assist with why the entire website www.snowglobewhistler.com not working?

Thank you
Snowglobe Photo Booth


#7

Hi again.. well the www.snowglobewhistler.com is now working. Although it is not consistent (sometimes it works and sometimes it doesn't.. any ideas about that?)

As for the "www".. as mentioned I have re-entered the CNAME "www" points to snowglobewhistler.com. Hopefully it works in 48 hours...Is there any reason why I have to do this again (when it was working fine for a few months?)
Thank you!


#8

Hi @Snowglobe, kindly look in my reply to you above :). There is still one A Record that is pointing to some other server.

This extra A Record should be removed in DNS settings on the domain.

On the CNAME record on the domain, make sure that "www" or "www.snowglobewhistler.com" is pointed at host proxy.webflow.com:

This article should help: http://help.webflow.com/faq/how-do-you-point-a-godaddy-domain-to-a-webflow-site

You can also ask Godaddy support for help with DNS settings: http://help.webflow.com/faq/how-to-politely-get-your-dns-provider-to-update-your-dns-settings-for-you

Let me know if you get stuck, I am here to help smile Cheers, Dave


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.