Streaming live at 10am (PST)

Sections disappearing on 100%


#1

Just started a new site, sections shrink to about 0% when i give them a height and width of 100%. First time iv seen it happen, not sure whats going on.
It acts fine if the height is set in pixels.

This is a photo when i just drop a section into the body and gave it a class.

This is what happens after i set the height and width at 100%. The section shrinks to what looks like 0% and just sticks to the top of the page.


#2

An element needs computed dimensions to be displayed. Setting the width at 100% may be of, but the height would mean 100% of an unknown dimension, so it's not calculated.

If you want a section height to be 100% of the visible window, you have to set its height to 100%, and the height of the element to 100% too.


#3

Hi @vincent thank you for the reply.

The Section's parent element is the body, which is minimum 100% so it should spread though the screen.

Iv already designed on site with webflow, that never happened before so im not sure perhaps its a bug?


#4

Not its min height, its height.

Can you please share your project’s public link so it's easier to understand your issue?

Learn how to do it here: http://help.webflow.com/sharing-your-public-webflow-site-link


#5

Hi @vincent -
https://webflow.com/design/ichp-singapore?preview=f9995dda4b3107ca4ac61e6f108afae0

I left one section size on auto and the other one is on 100% which you cant really see but you can find on the navigator tab.


#6

@Nir. Your body height attribute is set to auto your the public site. Double check.


#7

I dont understand, the site doesn't show what you said it should... hero section has no height, not even in %. 100% would not work, you need to put 100% to the body too. WHat are you trying to do?


#8

Im trying the same it doesn't work :frowning:


#9

Hi @Baseem_Ahmad, I would suggest to create a new post with your details, and then we can take a look and try to help :smile: Here are the posting guidelines: http://forum.webflow.com/t/posting-guidelines-for-the-need-help-category/8094


#10

If you want a section to be 100% hight just use vh (viewport hight). You just need to enter 100vw and the section is a high as the screen :smile:


#11

Thanks alot for your help i found the soulotion :smile:

But i have one problem i tried to find asoultion for it ... And as this is my first time in webflow and a dsigner not coder ... I did pop up modal but the website keep scrolling underneath which when i clost the modal i find my ls lf in other place :frowning:... Can i share my website and help me how can i do it ... As some of the people here suggeted to copy paste a code but and i did but it did not work 😔 !!!

Thanks in advance for your help and time.

Baseem


#12

https://preview.webflow.com/preview/baseems-fantastic-site?preview=5d4fa806aa7377a9f5dd179b0f055fa9

this is my website, and im trying to solve the scrolling issue underneath the pop up modal :smile: i appreciate your help guys on this

regards,


#13