Streaming live at 10am (PST)

SEO Quake analyse

#1

Hey There,

I analysed my website and found errors I can’t solve.

1 is about robot.txt
2 is about multi-language specification. But I specifised them /fr /en /nl in webflow

Would appreciate your opinion on that

#2

can you pls provide eng version of analyze?

#3

I would like to help you but I can’t translate an image. I need more to go on then,

You can look at this Article for info on how to work with your site robots.txt settings.

1 Like
#4

Hello @webdev!

I know understand the robot.txt. I don’t have any page to disallow do I still need to add " *User-agent: *" ?

Regarding the multilingual it says: “You don’t specified a language for your website”
But in my case, I have set :

www.happydesk.be (HOME)
www.happydesk.be/fr-page1

www.happydesk.be/en-page1
www.happydesk.be/en-…

www.happydesk.be/nl-page1
www.happydesk.be/nl-…

=> Maybe better practise would have been this way?

www.happydesk.be (HOME)
www.happydesk.be/fr/page1

www.happydesk.be/en/page1
www.happydesk.be/en/…

www.happydesk.be/nl/page1
www.happydesk.be/nl/…

=> Does this affect my SEO?

Thanks!

#5

The default is no blocking. So you don’t need to add anything unless you want to restrict by user agent. The sitemap.xml is added automatically by webflow.

Webflow does not currently provide the ability to set the lang="" attribute on the HTML element. For SEO - your best option is using Google Webmaster Tools to tell Google your default country.

1 Like
#6

You can add lang="" in your HTML element from the bottom of the Custom Code settings page:
CloudApp

I know this is confusing to find, but it’s there :slight_smile: Hope this helps

1 Like
#7

Whoops! How did I miss that? Thanks, @PixelGeek.

@palombokevin - I would recommend still adding a default country in Google’s webmaster tools.

2 Likes
#8

@palombokevin - Here is the university article covering the feature. It also has information on how to set the language code for a multilingual site.

Google reference - > https://support.google.com/webmasters/answer/189077?hl=en

2 Likes
#9

That’s awesome @webdev and @PixelGeek!

Look, now is everything checked :smiley:

I will check that link talking about multilingual too

Great weekend guys!

1 Like