Streaming live at 10am (PST)

SEO settings, don't work as expected, need advices

Hello everyone ! :wave:

I have a little problem that I don’t understand and I need some advice about it!

I recently put my website online (about 4 days ago) via Webflow, which you can discover right here: www.kevinbieron.com

However, I feel like I’m missing something on the SEO side because the meta description that appears when I type “kevin bieron” on Google is not the same as the one I put in the corresponding settings.

I’ve attached some screenshots that should help you understand my problem, and (maybe) solve it!

Thanks in advance, and have a nice day!

P.s : I don’t know if I’m using the “Global Canonical Tag URL” function, maybe that’s where it comes from?

Hi Kevin, Google’s algo determines what to show based on a variety of factors. It may use the meta description or it may not. You can learn more about this here → SEO Starter Guide: The Basics | Google Search Central

Hello Jeff @webdev !

I am aware of how to structure a web page to optimize it for SEO, yet the meta description that appears (“For full functionality of this site it is necessary to enable JavaScript. Here are the instructions how to enable JavaScript in your web browser.”) seems to be more of a bug or misunderstanding to me, which is why I wanted to know if I had done the SEO of the site correctly, at least in what I was able to share in screenshots

But thanks for your answer, I read the article which was very interesting !

The source code shows fine. It is a Google issue causing the rendering. However this may be related to not having your language set in your project settings. Might not be the cause but you should have it set regardless.