Streaming live at 10am (PST)

• Setting legacy Interaction to none doesn't disable the interaction


#1

When I try to disable a Legacy Interaction, I select an element with it and change radio from some_interaction to None. But the interaction is not being disabled this wa, it stays as data-ix=“some_interaction” in code.

I found a workaround in creating an EMPTY interaction and switching to it, not to “None”. This way the element loses an interaction., which is what I want in this case.

The bug appears in different projects (most of them created before IX2).


• Legacy interactions set to none still have interactions applied
#2

@ma11k i found the same behavior in My projects. Did the same as you. Created a new interaction called none


#4

Hi @ma11k and @JanneWassberg

Thanks for reporting about this issue. The team has been informed and we’re working on a fix.

I’ll post any updates here in this thread.

Thanks again for reporting this and for your patience as we fix the issue.

Kindest regards,
Anna


#5

Hey @JanneWassberg and @ma11k,

we’re still investigating this issue with legacy interactions. Another workaround to ensure that an element has no interaction applied to it to create a new legacy interaction, apply that to the element, then delete the new interaction. That should remove the interaction completely.

This workaround will remove interaction code from the site and allow you to apply a new interaction from the interactions 2.0 panel.

​Hope this is helpful until we fix the issue.

Kindest regards,
Anna


#6

​Great news! We have pushed a fix for this issue. To apply the fix, you’ll need to find the elements with those legacy interactions and manually set the interactions to “none”. Even if it’s already set to none.

​If you need further help with this step, please let me know.

​Cheers


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.