Streaming live at 10am (PST)

Setting up a reference from one collection to another and editing collection fields


#1

This is proving I have material in my collections. I have an author. Also I have blog posts. And I have services. Though it will not let me select ANYTHING except the title of blog, summary of blog, and the 3 date options. The body of the post is no where to be found. Or any of the author options. Nothing is available for me to use. I am trying to create the authors information to link to the boxes I have made. Though it does not give me that option at all.

It won't let me take a screen shot of the options it does provide me due to windows button closing the drop down.

here is a link to the website.
My website

Edit: If you go to blog page. Try to change the author name or any of the content to anything but those 5 items listed. (Published/Created/updates/summary/title) those are my only 5 options anywhere. I don't know what I am doing wrong though I don't think this is how it is suppose to work. I have tried everything and watched every video.


#2

Hi @monstermage, thanks for the post and the read-only link. From what I can tell, the blog posts collection does not yet have an authors reference field created, so to link to the authors collection, create a reference field and add that to the blog posts collection.

Create the reference to the Authors collection. Save the new field and then the collection. Now the Authors reference will appear in the Blog Posts collection. If you are trying to enter info in fields that do not exist, add those to the collection.

Take a peek at a quick video I made:

I hope this helps!


#3

Awesome! yes I see why it wasn't showing the authors and other stuff now. Though when I go to my blog template. I am still not able to select anything from Blog posts except for the title and summary.

@cyberdave
I am not able to use any of the collection data for my blog posts except for the summary and title.


#4

Hi @monstermage, I just realized I uploaded a video with no sound, sorry about that.

Take a peek at how to bind those fields to elements on your template page. The post body is not showing up, because there is no Rich Text Field yet added to the page.

Let me know if any questions !


#5

Blaaahh! Thats what I was missing. Rich text.
Thank you thank you thank you.

Perfect, thanks for the explanation. Awesome.


#6

Hi @monstermage , check out this article, how to style elements, within the rich text block: https://help.webflow.com/article/how-to-style-rich-text-elements


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.