Streaming live at 10am (PST)

Show / hide interactions not fully working


#1

Hello Experts,

I have a show/hide interaction going in my site. i seemed to have set the first three up perfectly BUT when I try to set up a 4th or 5th the exact same way those won't work. It all feels really buggy. Can u tell me why this is not working beyond the third question? Am I not setting this up correctly? I have watch two different Webflow tutorials on this already.

here is the share link
https://preview.webflow.com/preview/mystrodriversite-f108de72-8bb5c80b55d14?preview=74baef0746a2998563264b1f650778ee

not sure if this will help but here is the link from my design environment to the page in question
https://webflow.com/design/mystrodriversite-f108de72-8bb5c80b55d14

the page name is: FAQ 2 Collapse

I've also uploaded a few screen grabs that may help.

Thanks for help on this.


Here is my public share link:
https://preview.webflow.com/preview/mystrodriversite-f108de72-8bb5c80b55d14?preview=74baef0746a2998563264b1f650778ee


#2

Hi @sdwayne,

Having looked at the structure of your interaction its seems over complicated.

The simple solution is below (i have added screenshots to help)

  1. Add the 'question 1' interaction to the FAQ collapse wrapper on all questions
  2. Update 'question 1' interaction to only effect nested elements

  3. Add 'answer 1' to all answers

  4. Delete all other interactions

Hope this helps @sdwayne


#3

Thanks @UrbansoulDesign.

I'll give this a shot and let you know what happens.


#4

@UrbansoulDesign - I did get the interactions to work. Thanks for your help.


#5

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.