Streaming live at 10am (PST)

Site down... billing question.. help?!

Hi Guys - bit of a crisis here. Our site was taken down because of an administrative issue with the credit card, which is now resolved. Didn’t help that we had the wrong email address associated with the billing.

This issue is that now I can’t seem to update the credit card details because I no longer have a plan?! (see attached) We did have both a Lite account and a Team - I can’t seem to update the Teams billing info, for the same reason (though it does say the site has been archived) - so am caught in a loop…

It seems the account has been ‘downgraded’ to ‘Starter’ - do I need to sign up for Lite again, and then activate the ‘Team’? - and will any data have been lost?

Any help appreciated - have mailed Webflow support, but nothing back.

d.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

I’m afraid forum users won’t be able to help. Support should answer you soon though. I can try to ping someone here to catch his attention. cc @cyberdave this seems to be an issue only support can resolve.

thanks Vincent… radio silence from Support at the moment, which is disappointing…

Hi Guys - bit of a crisis here. Our site was taken down because of an administrative issue with the credit card, which is now resolved. Didn’t help that we had the wrong email address associated with the billing.

This issue is that now I can’t seem to update the credit card details because I no longer have a plan?! (see attached) We did have both a Lite account and a Team - I can’t seem to update the Teams billing info, for the same reason (though it does say the site has been archived) - so am caught in a loop…

It seems the account has been ‘downgraded’ to ‘Starter’ - do I need to sign up for Lite again, and then activate the ‘Team’? - and will any data have been lost?

Any help appreciated - have mailed Webflow support, but nothing back.

d.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)