Streaming live at 10am (PST)

Site is showing in Google even though indexing is disabled


#1


Is this going to mess up my SEO when I move the page to the actual URL?? How do I stop Google from finding my site


#2

Hi @Mark_Mo_Lerner.

If the staging site was published prior to disabling Webflow subdomain indexing, search engines like Google will more than likely still have indexed those pages.

Now that this setting is enabled, though, Google won’t re-index your pages moving forward. In other words that setting isn’t retroactive.

You may want to look into how to remove pages that have already been indexed from Google’s results. You may find this resources helpful: https://searchengineland.com/removing-pages-from-google-53086


#3

Thanks! Ironically, that page is a 404 :wink:


#4

Oh no! Thanks for letting me know :sweat_smile: I updated it :slight_smile:


#5

@Mark_Mo_Lerner it looks like that result is not the staging site itself, but rather the actual showcase page on Webflow’s end. For example this is the URL that is showing as being indexed on Google: https://webflow.com/website/marks-fantabulous-project-8bb5d7

I’ve always thought it strange that Webflow indexes these pages - since it can hurt the SEO on the actual live site (as these showcase pages tend to rank high on Google).

I would assume that the only way to remove this would be to get rid of the showcase page and/or contact Webflow support for manual help.


#6

Will this work?


#7

@Mark_Mo_Lerner I don’t think so, that link is for your staging site, marking-fantabulous{}.webflow.io … Notice the it’s on the webflow.io domain. The link that is indexed by Google has nothing to do with this staging domain. The link Google indexed is:

https://webflow.com/website/marks-fantabulous-project-8bb5d7

Here you you can see the link is on the webflow.com domain, not the webflow.io domain. This is the link to the actual showcase page on Webflow’s end. To get rid of this page, you can disable the showcase. To do this check out this article, specifically the bottom heading “Disable Showcase”: https://university.webflow.com/article/showcase-a-project

This will get rid of that page, but as previously mentioned Google may still have it in their index archives. You may need to contact Webflow Support to try and get this cleaned up for you.


#8

I made it no longer a showcase page and reached out to Webflow’s support. Kind of a bummer - hopefully this isn’t too bad for my SEO when I launch.


#9

@Mark_Mo_Lerner I hear you. Please let me know their response if you can. In the past I’ve had a client reach out and wonder why the Webflow Showcase version of their site was showing in Google results (and was confusing their customers). Since then I’ve never showcased any site for this reason.


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.