Streaming live at 10am (PST)

Site Search empty


#1

Hi there

I have a problem with the site search result page.
All entries are the same but i did formatting the results in the sites settings with the collection tags.

Here is what it looks like.

Here are the settings for the search function.

Hand here ist the live site.

The search field is in the top right corner.

Here is my site Read-Only: LINK


#2

Hi @mark_artos

I’m not sure if what I see here is different to you or not, but it seems like you haven’t opted for webflow to index your site for Search result as the panel says Last indexed: Never

Take a look at the image and let me know if you have any furthers issues :slightly_smiling_face:

CloudApp


#3

Thank you for the replay.
I take a look at the settings.
The last index was 2. oct. so that should be ok…

Maybe on the read only link this infos are not available.


#4

Ah, You need to add the Meta info to all of your pages.

On the search page, you’re calling for that information, but on the pages and CMS pages you haven’t set it. Go to the page settings and add the dynamic meta information and this will solve your issue. :slight_smile:

You have done this for the “Kontakt” page, so if you search for “kontakt” the relevant search data is shown.


#5

Yes Kontakt works.
But i did it also for the Produkte Template Page.

There i have the search title from the collection item name and a description from the collection.
And all these sites don’t show in the result page…

I now add the URL as search result and this works fine.
Under the URL i have a textbox wir the search title. And this title is the same for every result…
But in the SEO/Search Setting the preview are correct.



#6

OK
When did you update the meta information? Was it before or after the last site index?


#7

I think after but i could be wrong.
Next possibility to index is in about an hour…

I wait for it and take a look after that.


#8

It sounds like that’s the issue. I’m sure this happened when I first used site search… "why is it not doing it! :weary: :joy: "

Let me know how it goes! :smiley:


#9

it could be. this settings i forgot to show before.
i will report.

thanks


#10

It works just fine after new indexing :grinning:


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.