Streaming live at 10am (PST)

Sitemap not being found and Google won't index site

Hello,

I’ve recently published this site: www.knowledgerecycled.com and spent weeks trying to get it to show up on Google. It’s the only company with that name, so naively thought it would be easy to get it high up in the rankings.

For ages, Google Search Console wouldn’t even recognize it and wouldn’t index the site. I then changed the property to the full https://www.knowledgerecycled.com rather than the domain property (knowledgerecycled.com) and Google has indexed it but it’s showing on page 9 and won’t read the sitemap when I use the URL inspection tool.

When I upload the sitemap it says ‘success’ and there seems to be no problems.

I feel like I have tried everything - even playing around with the ‘default’ domain in the Webflow settings.

Can anyone help? I feel so desperate about it! I think it is actively affecting my business.

Thank you,
Julia


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Following on from this, Google won’t index the domain property knowledgerecycled.com at all and wouldn’t read the sitemap for that either.

knowledgerecycled.com redirects to https://www.knowledgerecycled.com so you should only be submitting https://www.knowledgerecycled.com/sitemap.xml as the valid sitemap, which is accessible.

Ranking is a separate issue once you know the site has been crawled. There is ZERO guarantee of placement in the SERPS since that is controlled by the algorithm. Your site has 81 results in Googles search index so it is crawled and visible. Now you can concentrate on building authority and other SEO tasks.

Thank you! I’ve already uploaded/submitted https://www.knowledgerecycled.com/sitemap.xml as the valid sitemap and it uploads fine, says ‘success’ and over 50 URLS found. However, when I use the URL inspection it claims it cannot find the Sitemap (see screenshot above). I think this might be part of the problem with the terrible ranking.

The status is not reliable and takes time to be updated. As I said there are 81 pages in the Google index. Ranking is a separate issue. If you want to learn about SEO then I suggest you start at https://moz.com/beginners-guide-to-seo or https://www.google.com/webmasters/learn/

Thank you for your help. I’m actually work with SEO regularly and do understand it - I’ve never encountered a problem like this before. It’s taken nearly 2 months to even get to this point with Google only just indexing the URL.

Im having the same issue and I consider myself an SEO expert.

@BradL= Does the sitemap load on your site or not when visiting the sitemap URL?

Yes, it does. But google doesn’t recognize it. There are two sitemaps submitted since August that Im having trouble with. I just posted about it on the forum 30 mins ago.

I just replied on your post.

Thanks all, Check if there is a general HTTP 301 error or not. if not, check whether you put “tick mark” in the Auto-generated sitemap in the SEO Tab(project setting), resubmit the sitemap in the search console. Sometimes it needs time to fetch it. Thanks