Streaming live at 10am (PST)

Sitemap.xml box on Site Setting Question


#1

Do I put this code in the Sitemap box? I got it from submitting my URL to www.xml-sitemaps.com? Not sure what is supposed to go in the box and what is supposed to go to Google Webmaster tools. Thanks ~Neal

    <?xml version="1.0" encoding="UTF-8"?>
    <urlset
          xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
                http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">
    <!-- created with Free Online Sitemap Generator www.xml-sitemaps.com -->
    
    <url>
      <loc>http://www.tracergroup.net/</loc>
      <lastmod>2014-03-17T19:31:49+00:00</lastmod>
      <changefreq>always</changefreq>
    </url>
    <url>
      <loc>http://www.tracergroup.net/contact</loc>
      <lastmod>2014-03-17T19:00:58+00:00</lastmod>
      <changefreq>always</changefreq>
    </url>
    <url>

Edited to use code formatting


#2

Hi @Neal_Gregory - yup, plop that into your Webflow dashboard here:

Make sure your sitemap xml is correctly formatted. I noticed that you're missing the closing </urlset> tag in the code you pasted above. After you paste it in and save it, make sure to publish your site again.


#3

Hi there,

After having pasted the code, saved it and published the web again, a new message pops up saying 'If you haven't already, use this URL when submitting your sitemap to Google Webmaster Tools'.
Then, back to my GWT's dashboard, I use my own custom domain and I get an error message if i just add /sitemap.xml to my URL. Any idea about what I'm doing wrong?


#4

Im having the same issue,
after the url is generated i go to google and they are asking for my
c47booths . com / [ past the link here]
but the code generated has c47booths.webflow.io/sitemap.xml
what am I doing wrong?


#5

Hi, we will use your custom domain in the sitemap.xml if you add a custom domain to your site settings. If you don't have a custom domain, you'll have to manually replace the urls in the generated sitemap xml, or create one yourself.


#6

my custom domain is set up and connected to my webflow site. the issue is when I generate it, the webflow url is used... I even tried unpublishing that version of the site and just keeping the custom domain published...

thank you for the response.


#8

I just want to join in on this. Got the same problem as @hmoozwalrus. Got my custom domain set up and running well, tried to make a sitemap in the Webflow Dashboard using the "Generate Sitemap" button but instead of my custom domain I also get the .webflow.io domain instead.

I might got this wrong, but do I have to generate a sitemap externally and then paste in the code in the sitemap box in the Webflow Dashboard and THEN click "Generate Sitemap" button to generate a URL for Google Webmaster Tools?

Or is the "Generate Sitemap" button used to actually create a sitemap and also generate a URL to the sitemap to be placed in the Google Webmaster Tools?


#9