Streaming live at 10am (PST)

Slider Autoplay not stop after click


#1

Searhed forum - many requests for autoplay resume after user click… Not find code solution.

I have same request - need animated seqence of slides never stops - even after user click.


#2

As usual… Reply to myself :

In footer custom code

$(document).ready(function() {
	$('#sliderAuto').mousedown(function(e) {
		e.stopImmediatePropagation();
	});
})

My solution is for slider with no user control - arrows, etc


#3

I’m glad you are able to figure this out within two minutes, even before anyone had a chance to read your question! You have serious custom coding skills


#4

Yep!!! 15 years of coding :slight_smile: Ex Flash and Java engeeneer, forced to downgrade to JS that i left 11 years ago!!! Welcome to jQuery :slight_smile: Webflow its savier for me in the era of Flash denial.


#5

Hey @Reacol,

This solution is awesome!
But unfortunately my slider requires arrows, so the user can navigate it. But I don’t want the autoplay to be disabled every time the user navigates to the next slide. Is there any solution you might be aware of when there are arrows for navigating the slider as well?

Thanks a bunch!


#6

Hi. Right now am not aware, but i’ll think of possible solutions…


#7

You’re awesome! :raised_hands:

In the meantime I am challenging myself to find a solution. Will keep you updated :blush:


#8

Hey Reacol!
I’m a complete noob at using Webflow, so sorry for this question.
Where exactley do I have to insert this code?


#9

#10

You need Footer code section.


#11
$(document).ready(function () {
  setTimeout(function () {
  $('.w-slider').unbind('mousedown');
  $('.w-slider').unbind('touchstart');
  }, 500)
});

#12

Hi Realcol,

I added the code to the Footer section but it doesn’t seem to be working for me.
Can you please have a quick look? Thanks!
M

http://upform-v1-5.webflow.io/


#13

Have you published site after footer was added? I doesnt see any footer section inserted…
See working example : http://martp.webflow.io/


#14

Thanks for checking, I had removed temporarily the code yesterday because it was displayed at the end of the page. I added the code again and it doesn’t work. By the way, there’s no slider in the link you sent.
Thanks again.