Streaming live at 10am (PST)

Slider does not work when the site is published

Hello!
I can’t find a solutions and I need a help.
I make a slider like lighbox - it opens with interaction after clicking on triger and slider works in preview mode, but does not work when site is published - it’s frozen and static.

Thanks.


Here is my site Read-Only: https://preview.webflow.com/preview/edinburgh-4?utm_source=edinburgh-4&preview=3b05d6030cae3f3fb0918f7179a95ae5&mode=preview

Here is my site: https://edinburgh-4.webflow.io/gallery

Hi, @Skumigs ! :wave:

First off, thank you so much for getting posting your slider not working. I imagine that is not what you were expecting, but I’m happy to help!

I was able to create a clone of your project and reproduced the same issue that you’re experiencing. This definitely looks to be odd behavior.

After reaching out to the team, and found that this is a bug that you’ve come across. The issue seems to be occurring because the slider is set to display:none on page load.

As a workaround, you may do the following:

1- Remove Display: None from Set as initial state in the Element trigger interaction .
2- Create a Page trigger > When page finishes loading with display: block and then display: none
… as initial state of the slider .

You may read more about this workaround here.

I completely understand how frustrating it can be when something doesn’t work as expected.

Our team is currently working on this issue, and I’d be happy to let you know once the fix is available as soon as possible.

Hello!

Ben here with the Webflow Customer Support Team!

​I wanted to let you know that our team recently pushed a fix for this issue. You can now set the slider to display: none and use an interaction to show it.

​Before the fix, when you showed the slider with an interaction it wouldn’t work properly. Now, using an interaction to show the slider shouldn’t have any impact on how it works!

​If this doesn’t resolve your issue, please reach back out and I’ll be happy to assist you further!

Hi!
Guys you are great! The issue is fixed and the slider now can be used with display setting: none on initial state! Thanks a lot!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.