Streaming live at 10am (PST)

Slider Image disappears after one cycle through


#1

Hi there,

I have a logo slider set up with infinite scrolling. However, when I cycle back to the original four logos, whichever logo is in the fourth spot disappears from view.

(I have four unique logos in there and then filled the last four with the same logo to be updated later).

Here's what it should always look like:

And here's what it looks like after cycling through:

Can anyone explain this behavior and recommend a solution?

Thanks,
Danny


Here is my public share link: https://preview.webflow.com/preview/occhiali-eyeglass?preview=95a1e48d35922c1816624d1fe942a439
http://occhiali-eyeglass.webflow.io/


#2

Hi @Danny_Weilandt

Now you are using a different slide for each logo.

Create a div inside 1 slide and call it for example slide-wrapper and put your 4 logos ("CarouselLogo" class) in it.

Set you CarouselLogo element to display : inline-block and width : 25%

Then you can just create a new slide - copy/paste the slide-wrapper and you will just have to change the images for the logos.

Hope this helps,

Best


#3

Hi @Blaise_Posmyouck,

I've done what you suggested with creating a div wrapper, but now when I slide to the second slide, it does not appear. Do you have any suggestions to make that work?

Thanks, really appreciate the help.

Public Link - http://occhiali-eyeglass.webflow.io/

Read-Only - https://preview.webflow.com/preview/occhiali-eyeglass?preview=95a1e48d35922c1816624d1fe942a439


#4

Hey @Danny_Weilandt

Don't use flexbox on the slide element, but on your slide wrapper div, so :

  • remove flexbox on your slide element
  • select your Slide Wrapper div and give it a height of 100% and display flexbox (justify center align center)

Then it should work :slight_smile: Feel free to ask if you still need help.

Best,

Blaise


#5

Bingo! That did it. Thanks, @Blaise_Posmyouck!


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.