Streaming live at 10am (PST)

Slider Interactions Not Working


#1

Hi!

I've applied interactions to the text on each of three sliders, and the interaction is only visible on the first slider on page load. I would like the interactions to be visible each time a slider appears.

The interaction is a simple move and fade. I've used the Slider trigger for all of them.

I've tried setting the delay to account for the timing of the slide show (Time Delay: 4000 ms) and the duration of the previous interaction (500 ms), to no avail.

I'm not sure if this message might have something to do with it:

The show also doesn't autoplay beyond the second slide, but I'll deal with that as a separate issue - I'm including the information here in case that has something to do with the interactions not working.

Thank you for your help!

https://preview.webflow.com/preview/nanatoo-export-copy-panic?preview=7c32f35ec653d6fe56d21b2bb18ad281


#2

Hi @tkister,

Could you, please, point us which page has that slider with interactions?


#3

Sure! It's the Home page. :grinning:


#4

Ok, so trick with slide interaction is that you need to add delay (waiting time) as the first step of the interaction for make it visible. There is duration time in the slider setting. Set delay, at least, half of that time and you will see interaction works.

Also, I would suggest applying interaction to "slider container" instead of every piece of text.

Regards,
Anna


#5

Thanks for the reply, sabanna! :grinning:

As shown in the screenshots, I have already added the delay to the first step of the interaction, under "Slide Into View."

The slider duration is 4000 ms, so I set the delay to 4500 ms.

I tried doubling the delay time to 9000 ms. I also did as you suggested and applied the interaction to "slider container," instead of each text block.

They still aren't showing...

Should I be adding it somewhere else?

Thank you!


#6

Not the time between slides, but slide duration, now long is sliding animation by itself. 4000ms it is now long slide stays on the screen.

I will go to check read-only link for more details


#7

I see what you mean... So the slide duration is 500 ms. I tried reducing the initial time delay on the interaction to 1000 ms.

No change.

Here's a screencast that shows the setting I'm changing.


#8

Hi,
I thought I'd jump in here in case Sabanna is busy. :slightly_smiling:

You should have the wait time as its own step, then add another step with your movement. My screenshot is of one of my interactions,but you'll see the idea.

Hope this helps.


#9

@:ctotty

Yay! That fixed it! Thank you so much! :hibiscus:


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.