Streaming live at 10am (PST)

Slider with flexbox settings not visible on phone


#1

Hi guys!

I am almost finished with this site, but I just found out about something very annoying. On my pc everything seems to be fine, but when I look at the website on my phone (it's published: najz.webflow.io) the slider on my home page (almost at the bottom) magically disappears. I think it has something to do with the "flexbox" settings, since my menu button was also acting when it was set to "flexbox" in mobile.

Is there someone who knows the cause of this problem and how to solve it?

(If you follow the public share link, before you can see the "home page", you have to set "home div n" to invisible)

Thank you very much!


Here is my public share link: https://preview.webflow.com/preview/najz?preview=b981091e7ad0fd24fba6879980729c99


#2

Hi @Martino, I thanks for the question, I have a couple of suggestions.

First, use the default styling for display and position for the slider and mask styles.

Slider Settings class style:

And then remove the style that is assigned to the mask completely. Republish and take a look on the phone view. What phone by the way? I did this styling on the slider and then the slides show correctly for me on mobile. You can position the content in the slide, in the container class you have assigned:

Since you have the flex on the container, no need to put it on the Slider main element.

I hope this helps!


#3

Thank you @cyberdave!!

It worked!!


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.