Streaming live at 10am (PST)

Slides are appearing vertically, not horizontally


#1

Not sure why but this slider is appearing vertically.

Why?

https://preview.webflow.com/preview/frltest?preview=ffe4af8f2f8f8f26803f4e8ebf2b5889


#2

Anyone?

@cyberdave
@Waldo
@sabanna


#3

Hello, @TriceWD

What page has this slider?


#5

It's the Garden page.

I've also had this issue and only fixed it when I removed the formatting and started over. I think it's because of the "position". If you make s1 position auto and when you start formatting s2 as position auto, it should clean this up.


#6

Avoid to change SLIDE position and display settings. It is what usually destroying slider functionality. If you need to do this the best way is to add a div (wrapper) and put all content inside it.


#7

Setting the position to auto did not solve this issue.


#8

I don't understand what you're asking me to do.

Can you be more specific?


#9

Here is the video screencast of what I mean:


#10

Much appreciated.

So basically all I would need to do is wrap the contents of each slide in it's own div...?

And remove the class name on each slide...?

Sorry for the confusion, "Avoid to change SLIDE position and display settings." was throwing me off.


#11

Yes. Sometimes I see the cases where designer makes SLIDE position: absolute or display: block or display: flex. It is what I was talking about.

So by removing class from the slide itself and using wrapper (div) with that class will save your content design idea and will NOT ruin slider functionality


#12

Essentially, when you remove the formatting, you are setting the slide widget's position and display settings to auto.


#13

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.