Streaming live at 10am (PST)

[SOLVED] Can`t add span link to certain paragraph element


#1

I`m simply trying to add a link to one of the words in my spotlight-2 div inside the p-spotlight paragraph. I highlight the word I want and usually a little toolbar will show up with a link icon to click, but it does not inside this div for some reason.


Here is my public share link:

https://preview.webflow.com/preview/library?preview=57259174f999385f0f8315c3ebebfe3b


#2

Hello @rhami

I can't find the div you're reference

Can you post a screenshot of the element please?


#3

Hi @rhami

Same here. I can't find it either. Can you point it out so we can take a look at it?


#4

Go to Strategic Priorities section, click Show More, then under Strategic Priority 1 click How We Did it and scroll down to see the spotlight div


#5

Allright, that's a bit weird because the toolbar doesn't show up for me either on that particular div. I does show up on the paragraph above it e.g "Searchable catalouge". I'm reporting this as a bug.


#6


#7

@cyberdave.

This is what it looks like in relation to the problem stated above. (I had to remove opacity 0%)

Preview link: https://preview.webflow.com/preview/library?preview=57259174f999385f0f8315c3ebebfe3b6


#8

Thanks Steven,

Is there anything I can do about this? Any sort of workaround maybe?


#9

Well you can try to maybe insert a text link and set it to "display inline" (the ABC button). That's the only work around I can come up with at the moment.


#10

I can add a text link but how would I make it continuous with the flow of the paragraph?

Right now if I add the text link I can't just stick it in the middle of the paragraph even when setting it to display inline


#11

Any help would be really appreciated, the website needs to be done this week and I need to have the links in there...


#12

Hey guys!

We're looking into this. The bug here is that the toolbar with bold, italic etc shouldn't be hidden off the canvas. As you can see moving the entire spotlight div back from -85% (why?) is revealing the toolbar in top-left corner of the node.

So... few things here:

  1. @rhami Try not to use negative margins of THAT value. That is going to - at some point - break your design.
  2. We'll fix this bug, where the toolbar should never go further than the border of the canvas :slight_smile:

Cheers,
Bart


#14

Hey guys!

We just pushed a fix :slight_smile: Should be good now!


#15

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.