Streaming live at 10am (PST)

[Solved] Class not appearing in selector


#1

I've created a class and applied it to an object but now whenever I want to apply it to something else it doesn't appear in the helper selector as I type its name. If I type in its full name the class is applied though


#2

What's the context exactly? Weblfow CSS is a bit different than normal CSS. If you pile up classes, they don't necessary get the CSS properties you think they would.

For example if you give 2 classes to an object, like .box .specialbox, the specialbox class may not be proposed for any other element, because Webflow considers a unique property for .box.specialbox. Specialbox properties may not be transferable to an element called .specialbox or .box2.specialbox.


#3

the context is, I have: style1/sub-style1, now I have an element with style1 applied and I try to add sub-style1 to it. Sub-style1 does not appear in the helper window as a suggestion as I start to type but if I type the whole name the style is applied as expected.


#4

Found back a post that's worth reading:


#5

@vincent
I was just going to create this topic as well. It happened the day before yesterday, I hoped it was a temporary bug, but it's bugging me fore days already. Existing classes don't show up when I'm trying to write the, so now I have to memorize every class I create, or look them up by clicking on existing elements.

Please fix this. It's really hard working currently.

@thesergie @callmevlad :frowning: ?


#6

Yeah i ran into this as well. We're looking into it. Thanks!


#7

Woohoo! I think it works again :heart_eyes:


#8

Yep we pushed a fix! Thanks for your patience guys!


#9