Streaming live at 10am (PST)

[Solved] Conditional Visibility Problems


#1

Hi Webflow,

I'm playing around with the new Conditional Visibility feature but for the life of me it's not working, I can't see what I'm doing wrong either? Are there some teething problems with t?

So you know the issue I'm having, on my Dynamic Content Template I have set a simple Paragraph with Lorum Ipsum in it to "Show" and "Hide" on use of the CMS "Switch" but it doesn't work!? I've tried a few different ways but nothing?

here's the site: http://www.remarkablepubs.co.uk/remarkable-pubs
And the build: https://preview.webflow.com/preview/remarkable-pubs?preview=2f574ee49e8ce0c80e73ec5cc5424536

Thanks, Aaron


#2

Hi, I couldn't locate exactly where the issue is. .. can you point it to me with screenshots ?

Also, great site... hurray for Czech lagers, my favorites, and hurray for nice pubs, I love them, the look, architecture, everything.


#3

Hi @vincent,

Thanks for the comliment! :smile: and your help!

So in the CMS/Collections/Pubs and then choose any pub.

Some of the pubs have "Kitchen Times" others don't, so I want to make the "Kitchen Times Div" (Highlighted below)

"hidden" when the Kitchen Times input "Is Not Set"

Hope that makes sense?!

Aaron.


#4

Makes sense. Now I just tried if it was working the other way around and it seems it does...

On the following pub there are no kitchen hours set, and the block isn't displayed when I specify the opposite of what you did:

no?


#5

Well no, what I did seems to hide the block in any condition...


#6

@vincent Yeah. that's the issue I was running in to!?

I'm thinking there are some teething problems with this new function?

What do you think?

Aaron.


#7

I think.... I think you can't have the "set" value on a rich text field, maybe.

Can you delete the quote for the frst pub and try with the text field?

You can also create a switch, and manually set the switch and hook the visibility to it...


#8

No it's hidden either way!?

Very strange...


#9

Not really, it just means the system thinks it's always set.... can you try either of the cases I've described? I can't do it for you because I can alter your database.


#10

Yeah, have tried your suggestions the same situation... :confounded:


#11

@vince

So I have created a fresh page and a new collection to test, and it works in the Webflow builder but none on publish, screen shot below of in Webflow:

The below has a switch for featured set to on, for the second Blog post.

but on the published page nothing? http://www.remarkablepubs.co.uk/assets/assets


#12

Hello @vincent @Aaron!

Currently Rich Text is seen as "set" even if it's empty and that's why both is not set and equals nothing don't work. We are working on a fix for this :) Thanks for your post, guys and I'll let you know as soon as we have that solved! :)

Cheers,
Bart


#13

Hey @vincent @Aaron!

The fix has been deployed and should be working by now :) You might want to remove the Conditional Visibility settings and add them again in case they don't work right away.

Let me know if that works for you! :)
Cheers,
Bart


#14

Now "set" or "not set" are working but if I have the condition set to equal something, then nothing is visible. They condition that negates it makes it visible as well "show if not category > music". It's selected to music.
There should be a music icon in front of the #1 in the card under the main picture. http://pepperizer-playground.webflow.io/home


#15

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.